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LDAP login causes a "401 -- Unauthorized" browser error

Question & Answer


Question

This is part of a multi document set of documents on LDAP security troubleshooting. When Maximo and the J2EE server are configured for LDAP authentication, what causes a 401 -- Unauthorized error in the browser?

Cause

Enhanced Documentation

Answer

When logging into Maximo with LDAP configured, the browser generates a login dialog box for the user to enter their credentials. If the user enters credentials that fail authentication more than the maximum number of allowable attempts, the browser will generate a "401--Unauthorized" error. This error will also occur if a user clicks cancel in the authentication dialog.

The screen shot below shows a browser 401 error when LDAP authentication has failed.




To resolve this problem (as long as your account has not been locked by policy), exit the browser completely, then start it again.

Browser 401 errors not related to user login can also occur, but are outside of the scope of this document.



LDAP Troubleshooting Master Document



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Document Information

Modified date:
13 April 2021

UID

swg21304258