IBM Support

Requests stuck in the Pending Requests after a Reconciliation interrupted

Question & Answer


Question

How to get requests processed, moved forward from the Pending Requests queue, after a Reconciliation is interrupted.

Cause

If requests are stuck in the Pending Requests queue due to an incomplete Reconciliation, even after the locks (RECON_STATUS=1) have been removed (from the RESOURCE_PROVIDERS table in ITIM's database), what can be done to get them re-engaged by ITIM to be processed through to completion?

If a Reconciliation is interrupted and not allowed to complete normally, and the Service is set to 'Lock Service During Reconciliation', then Requests for that same Service that were submitted before the Recon completed could get stuck in ITIM's Pending Requests queue. When a Recon is run for a Service that has the "Lock Service During Reconciliation" flag checked, the Recon process will establish locks on the Service to prevent any requests from being sent to the Adapter until the Recon process has completed. Any request submitted to this Service during this time will sit in the Pending Requests queue (stored in the REMOTE_SERVICES_REQUESTS table in ITIM's database) with a 'Pending' status.

Then, at the end of the Recon process it will check to see if there are any requests for the same Service that were held up due to the active Recon. If there are any found then they will normally be engaged and processed to completion. However, if the Recon process was interrupted (WAS, DB, etc shutdown while the Recon is processing for example) then it is possible that these Pending Requests won't be recovered by the Recon process since it never reaches that end/completion point.

Answer

These requests will only be recovered by a Reconciliation process completing as the requests were flagged as dependent on the completion of a Recon for this same Service. The easiest way to progress these Pending Requests is to first ensure the Recon locks for this Service have been cleared (see Technote/DCF http://www-01.ibm.com/support/docview.wss?uid=swg21299504). Then, upon confirming this, simply submit a Recon request for this same Service. This can be as small as a single record (filtered) Recon, or a full blown Recon, as long as it completes properly. This will force the ITIM server to re-evaluate all Pending Requests for this Service at the end of the Recon process and re-engage them to continue processing.

TIPS:
A link/URL is provided for a simple technote which provides the basic steps to clear a "Reconcile Already Running" status manually.

You can run a single record filtered recon (eruid=jsmith), provided the target Adapter is capable, to reduce resource utilization and provide a quicker Recon completion time.

[{"Product":{"code":"SSRMWJ","label":"IBM Security Identity Manager"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Server","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"6.0;5.1;7.0","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Product Synonym

ITIM TIM SIM ISIM enRole

Document Information

Modified date:
16 June 2018

UID

swg21299507