IBM Support

Using Send to menu from Version Tree Browser results in "Access to an unnamed file was denied" error

Troubleshooting


Problem

Attempts to access an IBM Rational ClearCase version from the Version Tree Browser using the Send to menu option from the context menu results in the error "Access to an unnamed file was denied".

Symptom

Steps to reproduce:

  1. Create a dynamic view with default config spec
  2. On a Windows client, enter a shortcut to an editor (e.g. wordpad) to the users Send To folder, so that you can display/edit the contents of the file via the Send to option of its context menu
  3. In ClearCase Explorer display the version of a ClearCase element with several versions
  4. Right-click a balloon for a version not selected by the view and choose Send to -> wordpad
  5. You will see the error message, Access to an unnamed file was denied

Cause

This issue was identified as a product defect and logged under APAR PK54954


Note:
The problem was introduced in ClearCase 7.0.1_iFix001 and ClearCase 7.0.0.1 iFix004

Resolving The Problem

The defect has been resolved in the following updates for all Windows platforms (except Windows Vista):

7.0.1

ClearCase LT
V 7.0.1.1 iFix 2
ClearCase
V 7.0.1.1 iFix 2

7.0
ClearCase LT
V 7.0.0.2 iFix2
ClearCase
V 7.0.0.2 iFix 2



WORKAROUND:
  1. Temporarily checkout the version that you want to see
  2. Display the version using the Send to option
  3. Undo the checkout afterwards and you are finished

[{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"GUI: Version Tree","Platform":[{"code":"PF033","label":"Windows"}],"Version":"7.0.0.1;7.0.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21295707