Troubleshooting
Problem
If an IBM® WebSphere® Application Server is running on the same machine as the product then when the IP address of the machine changes the product may have difficulty reconnecting to the server. This scenario occurs most often in a wireless network environment where the IP address of the machine may change when moving from a local area network (LAN) to a wireless adapter.
Symptom
The product will not be able to connect to the local Application Server until the product is restarted, leaving the server in a 'Stopped' state.
Cause
This is happening because the JVM for the product is caching name lookup results
Environment
This only applies for products connecting to a WebSphere Application Server v6.1 install.
Resolving The Problem
In the IBM Application Server Toolkit for Application Server fixpack V6.1.1.3 and IBM Rational® Application Developer fixpack V7.0.0.3 the value for the JVM networkaddress.cache.ttl property was set to 1 by default to help resolve the caching of the name lookups for this scenario.
In addition to this change there have been two different copies of the orb.properties file made available to the product, which are located in a orbProperties.jar and orbProperties_local.jar file located in a 'classes' directory of the products com.ibm.websphere.V61 plug-in. The values in this properties file helps determine how the product connects to the Application Server. If only a local Application Server install is being used then renaming the orbProperties_local.jar to orbProperties.jar (while backing up the original orbProperties.jar file) will help address this problem. If both local and remote Application Server installs are being used then it is recommended to keep the original orbProperties.jar file.
Related Information
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Document Information
Modified date:
15 June 2018
UID
swg21287363