IBM Support

An internal error has occurred while processing the request, when opening attachments on ClearQuest Web

Troubleshooting


Problem

This technote explains why the error, "An internal error has occurred while processing the request", occurs when using IBM® Rational® ClearQuest® Web to open an attachment.

Symptom


The following error can occur when opening or viewing attachments with the ClearQuest Web Client:

An internal error has occurred while processing the request

Cause


Known causes for this behavior are:

  1. ClearQuest Web Services are not functioning properly
  2. An operating system patch was recently applied prior to the problem occurring
  3. Ports used by ClearQuest may be in use by another application
  4. Permissons are set too restricted on the cqattachments directory

Resolving The Problem

Try the following steps to troubleshoot this error:

  1. Restart the 3 ClearQuest Web services.
  2. Reboot the ClearQuest web server machine.
  3. Do a repair on ClearQuest:
    1. Stop 3 ClearQuest Web services and make sure no user is logged on and close all ClearQuest and ClearQuest Web windows.
    2. Open the Windows Control Panel: Start > Control Panel > Add or Remove Programs > Rational ClearQuest > Click the Change button.
    3. This brings up the install screen. Click the Next arrow and you will see the option to Repair. At the end, it should prompt that it was successful.
  4. Check if there were any recent Microsoft® patches applied on the web server before attachments stopped working.
    1. Go to Start > Control Panel
    2. Access Add or Remove Programs.
    3. Check "Show Updates" > Scroll down the Security Updates > Check for the latest one (number/date).
    4. Alternatively, use the Microsoft Baseline Security Analyzer to determine which updates are installed. This method is recommended with older versions of Microsoft Windows® that do not have the "Show Updates" option in the Add or Remove Programs screen.
  5. Check to make sure the ClearQuest ports are not being used by other applications. See technote 1258399 for details on default ports for the ClearQuest Web server.
  6. Make sure permissions on the web server for the following folder is set correctly:
    C:\Program Files\Rational\ClearQuest\cqweb\cqserver\cqattachments.

    Note: Users need access to the above folder in order to open attachments.

[{"Product":{"code":"SSSH5A","label":"Rational ClearQuest"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Web Java Server","Platform":[{"code":"PF033","label":"Windows"}],"Version":"2003.06.16;7.0;7.0.0.1;7.0.0.2;7.0.0.3;7.0.0.4;7.0.0.5;7.0.0.6;7.0.0.7;7.0.0.8;7.0.0.9;7.0.1;7.0.1.1;7.0.1.2;7.0.1.3;7.0.1.4;7.0.1.5;7.0.1.6;7.0.1.7;7.0.1.8","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21264211