IBM Support

SQL Server does not exist or access denied error, when logging into ClearQuest

Troubleshooting


Problem

This technote explains how to resolve the error, "SQL Server does not exist or access denied". This can occur when using IBM Rational ClearQuest with Microsoft SQL Server databases.

Symptom


This error occurs when logging into the ClearQuest tools:

    Error: Exception: Unable to logon to the SQL_SERVER database ""
    The vendor error message was:
    SQLDriverConnect: RETCODE=-1, State=08001, Native Error=17
    [Microsoft][ODBC SQL Server Driver][DBNETLIB]SQL Server does not exist or access denied.
    [Microsoft][ODBC SQL Server Driver][DBNETLIB]ConnectionOpen <Connect<>>

A similar error occurs when connecting to the database using the Maintenance Tool:
    Unable to login to the database using the following connection information: DRIVER={SQL
    Server};UID=<login>;DATABASE=<database>;PWD=********;SERVER=<server>.
    Verify that the information used matches the way the database was set up.
    The error message was: SQLDriverConnect: RETCODE=-1, State=08001, Native Error=17
    [Microsoft][ODBC SQL Server Driver][Shared Memory]SQL Server does not exist or access denied.
    [Microsoft][ODBC SQL Server Driver][Shared Memory]ConnectionOpen (Connect()).

Cause


There are several known causes of this error:

Cause 1

The SQL Server database server name changed, rendering the current connection information invalid. 1


Cause 2

SQL Server is not configured to use the necessary protocols. 2


Cause 3

In SQL Server 2005, the server is assigned an instance name. This is not accounted for in the connection information. 3

Cause 4

The SQL Server Browser Service is not running or properly configured to listen on the port or pipe for a specific database instance. 4

Diagnosing The Problem

First, telnet to the database server using the database port. For example, if SQL Server using the default 1433 port, then run the command telnet <dbServername> 1433

1. If the telnet works, then verify all your connection properties.
2. If the telnet does not work, then it means the port is closed. Verify if the port is open on the database server.

Resolving The Problem



Solution for Cause 1

  1. Login to the ClearQuest Maintenance Tool
  2. Select the menu option Schema Repository > Update
  3. Change the server name to reflect the new connection information
  4. Open ClearQuest Designer
  5. Select the menu option Databases > Update User Database Properties
  6. Change the server name to reflect the new connection information for all affected user databases

Solution for Cause 2
The SQL Server administrator must assure that the databases are configured to enable these protocols:
  • TCP/IP  
  • Named Pipes

SQL Server 2000:



Go to the SQL Server Enterprise Manager. Right click on the SQL Server instance and select Properties. In the General tab and Network Configuration window, make sure TCP/IP and Named Pipes are enabled. Restart the SQL Server service if you need to make these changes.



Note: Check the TCP/IP properties to verify which port SQL Server is running on. For example, by default, SQL Server is running on port 1433:



SQL Server 2005/2008:

Go to to SQL Server Configuration Manager. In SQL Native Client Configuration > Client Protocols, make sure TCP/IP and Named Pipes are enabled. Restart the SQL Server service if you need to make these changes.

Solution for Cause 3

The server name must include the instance name. For example, SQL Server 2005 is hosted on the server Server1, but has an instance named PROD. The server name for the connection information must be Server1\PROD.

The connection information for the schema repository and user databases must be updated to account for this. See the first solution for details.



Solution for Cause 4

The SQL Server administrator must assure that the SQL Server Browser Service is running. It must also be configured to listen on the port or pipe that the database instance is using.

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Document Information

Modified date:
16 June 2018

UID

swg21264199