Troubleshooting
Problem
This technote explains why the error, FLEXnet Licensing error:-16,287, might occur when running a Status Enquiry in the IBM® Rational® Licensing, License Manager Tools.
Symptom
The full error message will look like this:
Error getting status: Cannot read data from license server system.
The license server system appears to be running, but is not
responding. If this persists, notify the System Administrator.
(The license server manager (lmgrd) and vendor daemon processes
should be terminated and restarted.)
Hostname: IBM-Shenk
License path: @IBM-Shenk;
FLEXnet Licensing error:-16,287
Cause
This is often caused by incorrect syntax within the license files used for Rational Common Licensing. This can be caused by a problem during the import of a license key or by tampering with the license file. This issue can also be the result of the overall path to the license file exceeding 32 characters. (See technote 1294897 for information on the length of the path to the license files.)
Resolving The Problem
After importing a license key, the server information in a license file might appear as:
SERVER hostname DISK_SERIAL_NUM=abcd1234
DAEMON rational "C:\Program Files\Rational\common\rational.exe\rational.exe"
DAEMON ibmratl "C:\Program Files\Rational\common\rational.exe\ibmratl.exe"
The proper format would be:
SERVER hostname DISK_SERIAL_NUM=abcd
DAEMON rational "C:\Program Files\Rational\common\rational.exe"
DAEMON ibmratl "C:\Program Files\Rational\common\ibmratl.exe"
This error may also be caused if there is no ibmratl.exe at the specified location. Be sure to check both the rational_server_perm.dat and the rational_server_temp.dat to ensure that the DAEMON lines are the same.
The SERVER lines will be slightly different by design.
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Document Information
Modified date:
16 June 2018
UID
swg21257688