IBM Support

Collect troubleshooting data for storage violation problems in CICS TS for z/OS

Troubleshooting


Problem

You are having a storage violation problem in CICS Transaction Server for z/OS (CICS TS). You would like to know what documentation you must collect (MustGather) so that the CICS Support team can diagnose your problem. If you gather this documentation before contacting support it will expedite the troubleshooting process, and save you time.

Cause

An overlay of storage that should not have been changed. For example, an overlay of storage check zones (SCZ) that surround task storage. In normal operation, CICS sets up four task-lifetime storage subpools for each task. Each element in the subpool starts and ends with a 'check zone' that includes the subpool name. At each freemain, and at end-of-task, CICS checks the check zones and abends the task if either has been overwritten.

Resolving The Problem

For the most up-to-date documentation, refer to Collecting CICS troubleshooting data (MustGather) for IBM Support in the CICS TS documentation. You will find the General information you should gather for every type of problem followed by the Component-specific information which includes Troubleshooting data for storage violation problems.

The following is the original MustGather information:







Collecting general information for all problems

If you have already contacted IBM Support, you can continue on to the component-specific MustGather information. Otherwise, go to Collect troubleshooting data for CICS products - Read first.







Collecting data for storage violation problems

Required (MustGather) data:
  • CICS message log that contains the messages DFHSM0102 or DFHSM0103 indicating that CICS has detected a storage violation.
  • MVS system dump taken automatically when CICS generates messages DFHSM0102 and DFHSM0103. Dumps can be suppressed if using SIT parameter DUMP=NO or the system dump table with the system dump codes SM0102 or SM0103.
  • CICS internal trace that is included in the MVS system dump when tracing is active. The trace should be at least 10240K and level 1 tracing should be on for all CICS components.


Optional (MustGather) data:
  • CICS auxiliary trace or GTF Trace when attempting to identify the transaction causing the storage overlay and it is necessary to keep a record of system actions over a long period of time.
  • MVS system dump for message DFHSM0103 resulting from using the storage checker. Storage chain checking can be turned on by using the CHKSTSK or CHKSTRM SIT parameters or transaction CSFE DEBUG with on of the following options:
  • CHKSTSK=CURRENT validates SCZs for task storage
  • CHKSTRM=CURRENT validates SAAs





Troubleshooting hints and tips



Diagnostic tips:
  • Review the logs and dumps generated at the point of failure.
  • Search the CICS support site for known problems using symptoms like the message number and error codes.
  • If you find a fixing PTF, see Ordering CICS products and maintenance for the options that are available to order CICS maintenance.
  • Gather the documentation and work with the CICS support team to resolve your problem.

Learn more about storage violations:


Exchanging data with IBM Support

  1. See Exchanging information with IBM Technical Support for FTP and email instructions using the IBM Enhanced Customer Data Repository (ECuRep).
  2. Go to the Service Request page to open or update a problem. If you have a SoftwareXcel enterprise edition for zSeries contract, you can also ask a non-defect installation and usage questions.

    Note: Always update your Service Request (problem record) to indicate that data has been sent.

If you need to speak to an IBM technical support representative call your country representative. If you need to speak to an IBM technical support representative in the US, call 1-800-IBM-SERV.

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Product Synonym

CICS/TS CICS TS CICS Transaction Server

Document Information

Modified date:
21 June 2018

UID

swg21214722