IBM Support

How to manually uninstall Rational Application Developer 6.0.x on Windows operating system

Troubleshooting


Problem

This technote explains how to manually uninstall IBM Rational Application Developer 6.0.x on a Microsoft Windows operating system.

Symptom

When you are trying to remove Rational Application Developer from a Microsoft Windows operating system, the InstallShield Uninstaller might fail, with the following message displayed in the InstallShield Uninstaller window:


    Errors occurred during the uninstallation

Cause

The uninstall program has failed, so a manual uninstall is necessary.

Resolving The Problem

In cases where the uninstall program fails to remove the product successfully, you can use the following steps to manually remove Rational Application Developer:

The manual uninstall steps are as follows:

  1. Delete the target directory where the product was installed
  2. Delete the RAT60 directory in the following location: %WINNT%\IBM
  3. Delete or Rename the vpd.properties file located in the %WINDIR% directory
  4. Backup the registry using Microsoft Windows backup procedures. (see Note relating to this step at the bottom of this technote)
  5. * Delete the following directory: C:\Documents and Settings\All Users\Application Data\IBM\LUM
  6. Edit the registry using regedit, and delete the following key: HKEY Local Machine\SOFTWARE\IBM\Rational\Software Development Platform

* Deleting the LUM directory deletes the license for all IBM applications that are registered on the system (such as WebSphere® Studio Application Developer). You can reinstall the licenses by following the steps documented in the technote linked below:


An additional technote listed in the Related information section addresses the issue of uninstalling WebSphere Test Environments (WTE).

It is not recommended that you manually uninstall the product, so these steps should only be used in situations where the uninstall program fails. If you have any uncertainty when performing these steps, contact IBM support to request assistance.

REGISTRY EDITS:

This solution contains information about modifying the system registry. Before making any modifications to the Microsoft Registry Editor, it is strongly recommended that you make a backup of the existing registry. For more information describing how to back up the registry, refer to Microsoft Knowledge Base article 256986

[{"Product":{"code":"SSRTLW","label":"Rational Application Developer for WebSphere Software"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Installation","Platform":[{"code":"PF033","label":"Windows"}],"Version":"6.0;6.0.0.1;6.0.1;6.0.1.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21190750