IBM Support

A ClearCase license is pulled each time you logon to Windows

Troubleshooting


Problem

This technote explains why logon to a Microsoft® Windows® host with IBM® Rational® ClearCase® installed causes a ClearCase license to be issued and provides steps on how to stop this behavior.

Cause

After logon to a Windows host, as user1, running clearlicense will show that a license has been pulled for that user id:


    C:\>clearlicense
    Licensing information for ClearCase.
    License server on host "CC_LICENSE_HOST".
    Running since Wednesday 02/20/02 16:06:04.

    LICENSES:
    Max-Users  Expires       Password [status]
    100          none      

    Maximum active users allowed: 100
    Current active users: 2
    Available licenses: 98

    ACTIVE users:
    User         Priority    Time-out in
    user1        none       59 minutes (at 13:20:42)
    user2        none       37 minutes (at 13:18:12)

There are a couple reasons this will occur:

1. ClearCase Doctor running in the background at logon will pull a license. This status tool runs by default after installing ClearCase. Following the system reboot, ClearCase Doctor prompts you to either:

    • Never Run at Logon,
    • Always Run at Logon, or
    • Run In the Background at Logon

Note:
A license is pulled by ClearCase Doctor when it is set to Always Run at Logon or Run In Background at Logon, and either of these selections becomes the default for each subsequent logon to the Windows host.

2. Views starting a logon will also cause a license to be pulled. When starting a view, there is an option to Connect to drive. By selecting none, the view will be accessible from the MVFS drive, which by default is M:\. If you choose to map the view to a drive, then the radio button for Restart at Logon is enabled. If it is left checked, the view will startup after you logon to the Windows host.



Note: VOBs set to mount at logon, or persistent VOBs, do not cause a license to get pulled.

Resolving The Problem

A ClearCase license is taken when you run a ClearCase client utility, such as cleartool or a GUI program.

When a license is pulled, then you keep it for an extended period, which by default is 60 minutes.

Entering any ClearCase command renews the license and the Time-out period. If you do not enter a ClearCase command for a substantial period, prior to the 60 minutes expiring, then the license is released and another user can pull that license.

For more information About Rational ClearCase Atria Licensing refer to technote 1128958.


To stop licenses from being issued at logon:

ClearCase Doctor:

Review technote 1148854 for instructions on how to disable ClearCase Doctor from running at logon.

Views starting at logon:

Review technote 1122505 in the section Mapped Network Drives for Views for instructions on how to disconnect the views.

When you restart the views from the ClearCase GUI, be sure the Restart at Logon is unchecked to ensure the mapped drives disconnect when you log off or restart.


ClearCase Start View



When you restart the views from the Windows GUI, be sure the Reconnect at logon is unchecked to ensure the mapped drives disconnect when you log off or restart.



Windows Explorer



[{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Licensing","Platform":[{"code":"PF033","label":"Windows"}],"Version":"2002.05.00;2003.06.00;7.0","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21171024