IBM Support

ORA-12640: Authentication adapter initialization failed

Troubleshooting


Problem

This technote provides a workaround for an error that can occur when using IBM® Rational® ClearQuest® with Crystal Reports® and Oracle® 8.1.7 databases on Microsoft® Windows® 2000.

Symptom

When trying to run a report using the ClearQuest client or web interface, you might receive the following error:


    Can't Exec Report - Caught an Exception in ../adole/reportmgr.cpp

The dbwin32 debugger indicates more detailed information:

    ADOConnection Open Failure
    Connect String : DRIVER={Microsoft ODBC for Oracle}; UID=*****;PWD=*****;SERVER=ORPL2
    Error : [Microsoft][ODBC driver for Oracle][Oracle]ORA-12640: Authentication adapter initialization failed

Cause

The problem is due to an Oracle product defect which prevents clients from connecting to databases.

Resolving The Problem

There is no resolution for this issue. The following workaround applies only to Oracle 8.1.7 databases running on Microsoft Windows 2000.

Here is the workaround suggested by Oracle to resolve this database connectivity issue:

  1. Check the file SQLNET.ora on Server machine under the directory ORACLE_HOME\network\admin for the following parameter:

    SQLNET.AUTHENTICATION_SERVICES=(NTS)
  2. Either remove the above parameter or edit it from (NTS) to (NONE), like this:

    SQLNET.AUTHENTICATION_SERVICES=(NONE)
  3. Next, stop and restart the Oracle database to apply the changes.
  4. The ClearQuest clients will now be able to connect to the database.



[{"Product":{"code":"SSSH5A","label":"Rational ClearQuest"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Reporting","Platform":[{"code":"PF033","label":"Windows"}],"Version":"2002.05.00;2002.05.20;2003.06.00;2003.06.01;2003.06.10;2003.06.12;2003.06.13;2003.06.14;2003.06.15","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Historical Number

157253380

Document Information

Modified date:
16 June 2018

UID

swg21147250