IBM Support

JR44164: CMVC 224366 - RESOLVE ERRORS CREATING THE SEARCH INDEX ON SYSTEM WHERE THE WAS PROFILE ROOT IS NOT IN <WAS>/PROFILES/.

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APAR status

  • Closed as program error.

Error description

  • When you run the setupSearchIndex tool it fails with an error
    like the one below:
    Cause:
    An error occurred while attempting to run task. The exception
    error was: An IO exception was caught. The error was:
    /opt/IBM/WebSphere/AppServer/profiles/demo/properties/soap.clien
    t.props (No such file or directory).
    ****************************************************************
    **
    ****************************************************************
    **
    
    Program exiting with exit code: 3.
    Search index setup not successful. An unrecoverable error has
    occurred. Check the log file for more information.
    
    If your WebSphere Application Server (WAS) profile path is in a
    location other than <WAS>/profiles/<WC_instanceName> then you
    note that, in the error message, the path to the profile is
    incorrect.  The utility is searching for soap.client.props in
    the wrong path.
    

Local fix

Problem summary

  • USERS AFFECTED:
    Users of WebSphere Commerce V7 with Feature Pack 2 through 5 who
    have created their WebSphere Commerce instance using the command
    line and who have specified that the WebSphere Application
    Server profile be located in a path other than the default of
    <WAS>/profiles/<WC_instanceName>.
    
    PROBLEM ABSTRACT:
    setupSearchIndex fails when the WebSphere Application Server
    profile is not in the expected location.
    
    BUSINESS IMPACT:
    This error delays the Solr search index creation and hence the
    deployment of the WebSphere Commerce system.
    
    RECOMMENDATION:
    

Problem conclusion

  • IBM has updated the method used by the setupSearchIndex tool to
    identify the path to the WebSphere Application Server profile.
    -------------------------------------------------------------
    The latest available maintenance information can be obtained
    from the Recommended Fixes for WebSphere Commerce technote:
    http://www.ibm.com/support/docview.wss?rs=3046&uid=swg21261296
    

Temporary fix

Comments

APAR Information

  • APAR number

    JR44164

  • Reported component name

    WC BUS EDITION

  • Reported component ID

    5724I3800

  • Reported release

    700

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt

  • Submitted date

    2012-09-21

  • Closed date

    2012-11-14

  • Last modified date

    2012-11-14

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    WC BUS EDITION

  • Fixed component ID

    5724I3800

Applicable component levels

  • R700 PSY

       UP

  • R600 PSN

       UP

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Document Information

Modified date:
14 November 2012