IBM Support

IT29300: INITCONNECTIONPOOL(DBICONN.C:XX) THREAD<YY>: ALL CONNECTION POOLS ARE FULL ARE SEEN IN THE ACTIVITY LOG

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APAR status

  • Closed as program error.

Error description

  • Problem description:
    The server encounters the InitConnectionPool error when the  db2
    connection limit of 9600 is reached and will become
    unresponsive.
    
    Symptom
    Issuing SHOW DBCONN would list the connections into DB2. For
    this APAR to apply, there will be many entries from creator
    sdutil.c for a select against table SD.Protect.History table as
    follows :
    
    IPC Pool 0:  Connections 480 (inUse 480, pending 0), Total
    Requests 149204 (Failures 0).
        IPC Connection 22573: threadId=375106,
    Creator=dbitxn.c(1696) InTxn=Yes Addr=0x7ffe262d07f0.
          Tsn=0:52633566, Resurrected=False, InFlight=True,
    Distributed=False, Persistent=True, Addr 0x7ffe3017cf70
            Start ThreadId=375106, Timestamp=28/04/19 16:25:31,
    Creator=sdutil.c(13206)
            Last known in use by ThreadId=375106
            Participants=1, summaryVote=ReadOnly
            EndInFlight False, endThreadId 0, tmidx 0,
    processBatchCount 0, mustAbort False.
              Participant DB: voteReceived=False, ackReceived=False
                DB: Txn 0x7ffd6cc74390, ReadOnly(YES),
    connP=0x7ffe262d07f0, applHandle=22573, openTbls=0:
          DB: --> RegSqlId=0x0F0000B6 SELECT for
    table=SD.Protect.History, executed(Yes).
    
    This can be caused by performing a manual select against the
    PROTHISTORY table from an admin command line interface,
    which in turn makes a call to sdutil.c to perform the QUERY
    PROTHISTORY command which is an undocumented command.
    Calling the command directly also causes this issue.
    
    Cause
    IBM Spectrum Protect has a limit of 9600 concurrent connections
    at any given time
    
    IBM Spectrum Protect Versions Affected:
    Server 8.1.x  versions on all supported platforms
    
    Initial Impact:
    Medium
    
    Additional Keywords:
    IBM Spectrum Protect, db2, connection pool,
    

Local fix

  • Local fix
    Restart the server to release db2 connections.
    

Problem summary

  • ****************************************************************
    * USERS AFFECTED:                                              *
    * All IBM Spectrum Protect server users.                       *
    ****************************************************************
    * PROBLEM DESCRIPTION:                                         *
    * See error description.                                       *
    ****************************************************************
    * RECOMMENDATION:                                              *
    * Apply fixing level when available. This problem is currently *
    * projected to be fixed in levels 8.1.7.100, 8.1.8.100, and    *
    * 8.1.9. Note that this is subject to change at the discretion *
    * of IBM.                                                      *
    ****************************************************************
    

Problem conclusion

  • This problem was fixed.
    Affected platforms for reported release:  AIX, Linux, and
    Windows.
    Platforms fixed:  AIX, Linux, and Windows.
    

Temporary fix

Comments

APAR Information

  • APAR number

    IT29300

  • Reported component name

    TSM SERVER

  • Reported component ID

    5698ISMSV

  • Reported release

    81L

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt / Xsystem

  • Submitted date

    2019-05-30

  • Closed date

    2019-06-13

  • Last modified date

    2019-06-13

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    TSM SERVER

  • Fixed component ID

    5698ISMSV

Applicable component levels

[{"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Component":"","ARM Category":[],"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"81L","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
13 June 2019