IBM Support

IT11342: PERFORMANCE MONITOR JOB SCHEDULE INCORRECTLY RESTARTS EVERY 5 MINUTES AFTER UPGRADE.

Subscribe

You can track all active APARs for this component.

 

APAR status

  • Closed as program error.

Error description

  • After job management functionality changed from using old
    (legacy) UI to new WebUI the upgrade from v.5.1.x to v.5.2.x
    should have updated the database to reflect this change.
    
    i.e.  The  PM jobs from schedule_type = 3 (repeatedly)  should
    be updated to Schedule_type = '1' , however, this update has not
    been accomplished.
    
    Scenario:
    TPC server was upgraded  from 5.1.0 to 5.1.1.3 to 5.2.1 to
    5.2.3 to 5.2.4 to 5.2.6.
    
    The scheduler with schedule_type = 3 has been inserted in early
    upgrade as it can be seen in the traceTPCInstall.log ,
    
    2014-05-15 20:23:08.775-0300 INFO
    com.ibm.tpc.install.backend.migration.JobMigrationDbWriter
    createNewJobSchedules newScheduleId: 31325002 and oldScheduleId:
    10049030
    
    2014-05-15 20:23:08.791-0300 INFO
    com.ibm.tpc.install.backend.migration.JobMigrationDbWriter
    createNewJobSchedules Creating new schedule: 31325002 based on
    Old Schedule: 10049030 for entity: 2010 with Type: 117
    2014-05-15 20:23:08.791-0300 INFO
    com.ibm.tpc.install.backend.migration.JobMigrationDbWriter
    createNewJobSchedules RUNNING: insert into TPC.T_SCHEDULE  (
    SCHEDULE_ID, CREATOR, NAME, DESCRIPTION, LAST_MODIFIED,
    LAST_MOD_USER  , ENABLED, SCHEDULE_TYPE, START_YEAR,
    START_MONTH, START_DAY, START_HOUR, START_MINUTE  , REPEAT_TYPE,
    INTERVAL_TYPE, INTERVAL_NUMBER, RUN_SUNDAY, RUN_MONDAY,
    RUN_TUESDAY, RUN_WEDNESDAY, RUN_THURSDAY, RUN_FRIDAY,
    RUN_SATURDAY  , TIMEZONE_TYPE, GLOBAL_TYPE, TIMEZONE, ARGUMENTS,
    ALERT_ID  , JOB_TYPE, HIGH_RUN_NUMBER, COMPUTER_ID,
    AVERAGE_DURATION, DELAYED_ENABLE)  values ( 31325002,
    'administrator', 'job_device_name', 'job_name', 1395431046638,
    'administrator', '1', '3', 2014, 3, 21, 16, 45, '2', '3', 1,
    '2', '2', '2', '2', '2', '2', '2', '1', '0', ' ', 'interval
    length = 300s; frequency = 300s; duration = 24h; duration type =
    hours', 10049030, 'R', 60, 0, -1, '0'  )
    
    
    The correct values for PM jobs with new WebUI (post upgrade)
    should be similar as follows:
     schedule_type = 1, RUN_MONDAY = 1,RUN_TUESDAY = 1,RUN_WEDNESDAY
    = 1,RUN_THURSDAY = 1,RUN_FRIDAY = 1,RUN_SATURDAY = 1,
    ARGUMENTS = 'interval length = 300s; frequency = 300s; duration
    = -1h; duration type = hours'
    
    
    Root Cause:
    
    Server upgraded to many different versions/fixpacks.
     TPC server was upgraded  from 5.1.0 to 5.1.1.3 to 5.2.1 to
    5.2.3 to 5.2.4 to 5.2.6.
    During one of these upgrades, the schedule for PM Jobs  were set
    to wrong values.
    The scheduler was set to start each PM jobs every 5 minutes .
    This may also cause a  overhead problem and deadlocks in db2 or
    other downstream issue(s).
    
    
    
    RECREATE STEPS:  Run Performance Monitor Job post upgrade.
    

Local fix

  • Contact Support
    

Problem summary

  • ****************************************************************
    * USERS AFFECTED:                                              *
    * TPC 5.1.1.x users upgrading to TPC 5.2.9 and earlier.        *
    ****************************************************************
    * PROBLEM DESCRIPTION:                                         *
    * When upgrading from TPC 5.1.x to TPC 5.2.x, Performance      *
    * Monitors settings (scheduled job settings) are not being     *
    * properly migrated to the TPC 5.2.x settings.                 *
    * That is, PM jobs are still executing on their previously     *
    * defined schedules instead of the "run indefinitely" scheme   *
    * that TPC 5.2.x employs.                                      *
    * This has the possiblity of creating a lot of overhead and    *
    * deadlock problems in db2.                                    *
    ****************************************************************
    * RECOMMENDATION:                                              *
    * If upgrading from TPC 5.1.1.x to TPC 5.2.x, recommend        *
    * upgrading to TPC 5.2.10+ to receive this fix.                *
    ****************************************************************
    

Problem conclusion

  • The fix for this APAR is targeted for the following maintenance
    package:
    
    | refresh pack | 5.2-TIV-TPC-RP0010 - target 2Q16
    
    Fixed in IBM Spectrum Control 5.2.10.
    
    http://www-01.ibm.com/support/docview.wss?&uid=swg21320822
    
    The target dates for future refresh packs do not represent a
    formal commitment by IBM. The dates are subject to change
    without notice.
    

Temporary fix

Comments

APAR Information

  • APAR number

    IT11342

  • Reported component name

    TPC

  • Reported component ID

    5608TPC00

  • Reported release

    524

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt / Xsystem

  • Submitted date

    2015-09-24

  • Closed date

    2016-03-04

  • Last modified date

    2016-03-04

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Modules/Macros

  • PM
    

Fix information

  • Fixed component name

    TPC

  • Fixed component ID

    5608TPC00

Applicable component levels

  • R520 PSY

       UP

  • R524 PSY

       UP

  • R528 PSY

       UP

[{"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SS5R93","label":"IBM Spectrum Control"},"Component":"","ARM Category":[],"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"524","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
22 February 2022