IBM Support

Installation Flow Manager client in a silent mode

Question & Answer


Question

Is it supported to install Flow Manager client in a silent mode by system user(NT AUTHORITY\SYSTEM)?

Cause

As system user "NT AUTHORITY\SYSTEM" is a specific user in Windows, to install flow manager with this user in silent mode fails.

Answer

Currently, it is not supported to install flow manager in silent mode by Windows system user like "NT AUTHORITY\SYSTEM". If installation is run by "NT AUTHORITY\SYSTEM", errors in installation log are as below:

........


InstallShield 12:29:33: Setting new security descriptor for 'C:\Program Files (x86)\IBM\Platform Process Manager\'
InstallShield 12:29:34: ResolveSidForAccountName: looking up account name 'JUSTICE\SYSTEM'
InstallShield 12:29:34: Failed to lookup account name, last error: 0x00000534
........

The error message say that installer tries to find a user(in this log, "JUSTICE\SYSTEM") but fails.

Overall speaking, the cause is Windows limitation of the system user. Log shows it tries to lookup "JUSTICE\SYSTEM", not "NT AUTHORITY\SYSTEM", although installer is run by "NT AUTHORITY\SYSTEM".

To follow the official document is highly recommended for installation in silent mode. That means, opening command prompt as administrator, and in the command prompt window, running the installation command "msiexec ....". For details, please refer to official document of "Installation Platform Process Manager on Windows".

Further information: Window system users do not contain only one "NT AUTHORITY\SYSTEM". In Microsoft official website it says ".....Its token includes the NT AUTHORITY\SYSTEM and BUILDIN\Administrators SIDs....".

N/A

[{"Product":{"code":"SSKTK2","label":"Platform Process Manager"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Not Applicable","Platform":[{"code":"PF033","label":"Windows"}],"Version":"Version Independent","Edition":"Standard","Line of Business":{"code":"LOB10","label":"Data and AI"}},{"Product":{"code":"SSZSHQ","label":"IBM Spectrum LSF Process Manager"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":null,"Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Historical Number

27194;499;000

Product Synonym

N/A

Document Information

Modified date:
17 June 2018

UID

isg3T1022553