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TBSM 6.2 "CTGTD1000E NullPointerException" error and "..." are being displayed instead of template names

Question & Answer


Question

TBSM 6.2 CTGTD1000E NullPointerException" error and "..." are being displayed instead of template names as shown in the attached screenshot.
template_error

Cause

The most common root causes are either related to a misconfiguration in terms TBSM data base name within TBSM<DB_name>_ds_update.properties files​ as I already documented here:
https://developer.ibm.com/answers/questions/500050/tbsm-62-updating-tbsm-data-sources-causes-ctgtd100.html
but the same could happen if the template artifacts are completely missing from TBSM DB.

Answer

To Check if this is the case, first you need to run the following command:

./getArtifact.sh -U db2inst1 -P db2inst1password -d /tmp -n ServiceTemplate.xml -c treetemplate

If the output mentions "The specified file or artifact was not found in the database" then the template artifacts need to be imported. The steps to be followed are documented below.

1. Create a file ServiceTemplate.xml within a directory of your choice with the following content:
 
<?xml version="1.0" encoding="UTF-8"?><treeTemplate name="ServiceTemplate">
<columnList/>
<templateTreeMapping primaryTemplateName="DefaultTag">
<actionMapping clickType="~popupMenu" actionName="ShowServiceInstanceEditor"/>
<actionMapping clickType="~popupMenu" actionName="InstantiateOneHopServiceMap"/>
<actionMapping clickType="~popupMenu" actionName="ChooseChildrenTool"/>
<actionMapping clickType="~popupMenu" actionName="ShowMemberTemplates"/>
<actionMapping clickType="~popupMenu" actionName="ViewTools"/>
<actionMapping clickType="~popupMenu" actionName="IntegrationTools"/>
</templateTreeMapping>
</treeTemplate>

 

2. Run the following command and check if the templates are not available.

 

./putArtifact.sh -U db2inst1 -P db2inst1password -name /Mihaela/tmpdir/ServiceTemplate.xml -c treetemplate

More details about putArtifact and getArtifact commands are located here:
https://www.ibm.com/support/knowledgecenter/en/SSSPFK_6.2.0/com.ibm.tivoli.itbsm.doc/adminguide/bsma_imp_exp_putArtifact.html https://www.ibm.com/support/knowledgecenter/en/SSSPFK_6.2.0/com.ibm.tivoli.itbsm.doc/adminguide/bsma_imp_exp_getartifact.html

[{"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Product":{"code":"SSSPFK","label":"Tivoli Business Service Manager"},"Component":"6.2","Platform":[{"code":"PF016","label":"Linux"}],"Version":"6.2,6.2.0.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Product Synonym

TBSM

Document Information

Modified date:
03 June 2019

UID

ibm10886411