Troubleshooting
Problem
Updates of a Watson Knowledge Catalog installation will not work correctly
Symptom
During install of an update of Watson Knowledge Catalog, an error occurs causing the update to fail.
Cause
During the initial install of the Watson Knowledge Catalog a default cryptographic key was registered for use by some modules instead of the unique key generated during the installation.
Resolving The Problem
Execution of the attached updatewkc.sh script should be performed immediately after the installation of the Watson Knowledge Catalog.
If you are unable to run the script before using Watson Knowledge Catalog, you will have two options.
- If you have already created Connection assets before the script is run then the credential information stored for those Connections will no longer be valid and will need to be re-entered.
- If you would prefer to keep the key originally used during installation, you can run the updatewkc.sh script with the option "--original". This would mean that any Connections created will still be usable. Keep in mind, however, that doing this means you will be using a known, and therefore insecure, key.
Document Location
Worldwide
[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSZJPZ","label":"IBM InfoSphere Information Server"},"Component":"Watson Knowledge Catalog","Platform":[{"code":"PF016","label":"Linux"}],"Version":"11.7.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
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Document Information
Modified date:
01 April 2019
UID
ibm10879181