Troubleshooting
Problem
ANS1802E error message is appeared while backup, although there is no any failed objects.
Symptom
dsmerror.log
ANS1802E Incremental backup of 'd$\xxx\YYY\zzz\*' finished with 0 failure.
example for backup log
Incremental backup for volume 'D:\xxx\YYY\*'
Incremental backup for volume 'D:\xxx\YYY\zzz\*'
....
Normal File --> 9,500,248,064 d$\xxx\YYY\zzz\12345678_abcdef.dmp *** Unsuccessful ***
Retry #1 Normal File --> 9,500,248,064 d$\xxx\YYY\zzz\12345678_abcdef.dmp [Sent]
ANS1802E Incremental backup of 'd$\xxx\YYY\zzz\*' finished with 0 failure
.....
Incremental backup for 'd$\xxx\YYY\*' is completed successfully.
Total number of objects inspected: 37,617
Total number of objects backed up: 426
Total number of objects updated: 0
Total number of objects rebound: 0
Total number of objects deleted: 0
Total number of objects expired: 45
Total number of objects failed: 0
Total number of objects encrypted: 0
Total objects deduplicated: 257
Total number of objects grew: 0
Total number of retries: 4
Total number of bytes inspected: 64.37 GB
Total number of bytes processed: 144.74 KB
Total bytes before deduplication: 34.31 GB
Total bytes after deduplication: 196.37 MB
Total number of bytes transferred: 196.68 MB
Cause
ANS1802E is appeared since the initial attempts to send several transactions are failed because some object are modified (please, refer to line with 'retry #1' in backup standard output log) during backup processing. However the next attempts is successful and as a result the number of failed objects is 0.
In the case of deduplication the client starts a new consumer session if the transaction is aborted (like in the current case when some objects are modified).
Since retries are successful the ANS1802E message with just 0 failures appears.
Resolving The Problem
Ignore the error message and return code 12 if "Total number of objects failed" is 0.
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Document Information
Modified date:
29 August 2018
UID
ibm10728933