IBM Support

ClearQuest Web record IDs created with wrong case when using auto-login URL

Troubleshooting


Problem

This technote identifies an issue that can occur in IBM Rational ClearQuest Web. Record IDs are created with the wrong case when logging into the Web client with a URL.

Symptom

You login to ClearQuest Web using an auto-login URL. When creating records, the prefix for the ID has the wrong case. For example, what should be the record ID of SAMPL00000001 is instead sampl00000001.

Cause

This happens if you use lower-case or mixed case in the database value (contextid) of the URL, instead of capital letters. This issue was identified as a product defect under APAR PK99764.

Resolving The Problem

This defect is fixed starting in versions 7.0.1.9 and 7.1.1.2. Upgrade to the latest version to resolve this problem.

WORKAROUND

Use capital letters for the contextid value of the URL. For example:

http://<server name>/cqweb/main?schema=7.0.0&contextid=SAMPL&command=GenerateMainFrame&username=admin&password=

[{"Product":{"code":"SSSH5A","label":"Rational ClearQuest"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Web Java Client","Platform":[{"code":"PF033","label":"Windows"}],"Version":"7.0.1.7;7.0.1.8","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
29 September 2018

UID

swg21409395