IBM Support

UCM CQ on Linux and UNIX based platforms - user login credentials in plain text by ps -ef command after running certain UCM action

Troubleshooting


Problem

This technote identifies an issue that can occur when using the IBM Rational ClearCase and ClearQuest UCM integration. On Linux and UNIX based platforms, the username and password can be viewed during certain operations.

Symptom

User name and password are made available to any user on Linux or UNIX based systems after certain UCM operation, simply by running ps -ef, listing of processes.

Linux Example:


[vobadmin@vobadmin]$ ps -ef
vobadmin xxxxxx 1 0 14:59 pts/0 00:00:00
/opt/rational/clearquest/linux_x86/bin/../../../common/java/jre/bin/java -cp opt/rational/clearquest/rcp/plugins/com.ibm.rational.clearquest.ucm.rcp_7.0.0/ucmrcp.jar com.ibm.rational.clearquest.ucm.cmdline.UCMCmdLine -cmd find -m 7.0.0 -d CQINT -u USERNAME -p USERPASSWORD -r

There are three scenarios that exhibit this behavior:

  1. Invoke ClearCase Project Explorer on Linux or UNIX, select an activity and right click to display its properties.
  2. Creating a new ClearQuest record from Project Explorer by doing a Right-click on a UCM-enabled stream, choose Properties -> Select the Views tab -> Select a view -> Select Properties -> Click Change -> Click New -> Select a record type and create a new ClearQuest record.
  3. The last is a continuation of scenario 2. Once the ClearQuest record is created if you selected that new activity and did an Auto-Transition this would also trigger this behavior

Cause

This issue was identified as a product defect under APAR PK75832.

Resolving The Problem

This defect is fixed in the 7.0.0.x, 7.0.1.x and 7.1.x releases, starting in these Fix Pack versions:

  • ClearCase 7.1.0.1 and ClearQuest 7.1.0.1.
  • ClearCase 7.0.0.5, ClearCase LT 7.0.0.5, and ClearQuest 7.0.0.5.
  • ClearCase 7.0.1.4, ClearCase LT 7.0.1.4, and ClearQuest 7.0.1.4.

Upgrade to the latest version of ClearCase and ClearQuest to resolve this problem.

Contact IBM Rational support if you require a Test Fix for this issue. The Test Fix is version specific: Be sure to identify the exact version and build label of ClearCase and ClearQuest running on your Linux or UNIX based platforms.

[{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"UCM: ClearQuest Integration","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"}],"Version":"7.0;7.0.0.1;7.0.0.2;7.0.0.3;7.0.0.4;7.0.1;7.0.1.1;7.0.1.2;7.0.1.3;7.1","Edition":"","Line of Business":{"code":"LOB36","label":"IBM Automation"}},{"Product":{"code":"SSSH5A","label":"Rational ClearQuest"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Integrations: IBM","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
29 September 2018

UID

swg21327851