Troubleshooting
Problem
This technote explains why IBM® Rational® ClearCase® VOB server processes are not starting after the server is restarted and results in the error message []vob_server(pid #): Error: Already running as pid #[] reported in the VOB log on Microsoft® Windows®, Linux® or UNIX®.
Cause
The VOB server was not shut down in a proper way leaving behind .pid (process identification) files in the VOB storage directory which prevent the vob_server process from starting.
Cause 2
If your clients use DHCP, delays in DNS propagation can cause this error as well.
Resolving The Problem
You will need to remove the lingering .pid files and restart ClearCase.
- Stop ClearCase services.
- Remove the .pid files manually using the operating system delete function.
- Restart ClearCase services.
Solution 2
The client hosts will need to update their DNS cache.
Consult your operating system guide for assistance.
Related Information
[{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"VOB","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF015","label":"IRIX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"2002.05.00;2003.06.00;7.0","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]
Was this topic helpful?
Document Information
Modified date:
29 September 2018
UID
swg21219443