IBM Support

Unlocking XMETA locks from jobs

Question & Answer


Question

How can I unlock an XMETA locked job? The job cannot be exported and when attempting to open the job, the following error appears: Unable to open the Job The Job 'TestJob' is locked by user 'dsadm' (SessionID '8F1B0326-4F7E-45A8-B8EC-EAA8C4780528') Do you want to continue and open a read-only view of the Job?

Cause

This issue arises when a lock still remains in XMETA for the corresponding job. Information Server will lock the job to ensure that there is no indeterminancy regarding the editing and saving of a job.

The most common causes of this is when a user has closed a client window unexpectedly (e.g. Force Terminate).

Answer

To remove the lock on the job, the following steps need to be taken:

  • Check that another user has not left the job open accidentally. The same error appears if another user has opened the same job in a Designer or Director client.
  • Explore the following in Information Server web client (http://<server>:9080):
    1. Open Administration tab -> Session Management -> Active Sessions.
    2. Select the session with the same 'Session ID' as the message.
    3. Disconnect selected session.
  • pre 11.3 remove using cleanup_abandoned_locks.sh. This occurs if the session is no longer displayed but lock is remaining in the XMETALOCKINFO table in XMETA repository. To perform this:
    1. Login to domain layer using either root or Administrator user (for Windows)
    2. cd /opt/IBM/InformationServer/ASBServer/bin (C:\IBM\InformationServer\ASBServer\bin for Windows)
    3. ./cleanup_abandoned_locks.sh -U <user> -P <password> (cleanup_abandoned_locks.bat -U <user> -P <password> for Windows) where user is suite administartor
  • From 11.3 onwards use xmetaAdmin.sh cleanupAbandonedLocks -dbfile ../conf/database.properties in ASBServer/bin directory when logged in as root or Windows Administator


    .

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Document Information

Modified date:
16 June 2018

UID

swg21469438