Troubleshooting
Problem
User launches the main Controller program. User clicks 'Reports - Run'. User selects a report, and chooses to run/send to Excel. Microsoft Excel opens. Report runs successfully. Afterwards, user closes Microsoft Excel spreadsheet (by clicking 'File - Close' in Microsoft Exce). NOTE: They do *NOT* close Microsoft Excel itself. Instead, Microsoft Excel is still running in the 'background' with no active spreadsheet open. Finally, user switches back to using the main Controller program. Inside 'Run Reports' user selects a different report, and chooses to run/send to Excel. User receives error message.
Symptom
Information
User XYZ already logged in to this database
[OK]
Cause
TIP: There are many different potential causes of this error message. For more details, see seprate IBM Technote #1347869.
By design, the Controller Excel link can only be logged in with user XYZ inside one Excel session.
However, it appears that some Microsoft Office updates (for example KB959995 for Office 2003 SP3) can trigger a problem in this mechanism. The Microsoft update changes the behaviour of how Excel creates a new 'session' of Excel.EXE.
- Before the update when launching a new Report, the report would open inside the *existing* session of Microsoft Excel (where the Controller Excel link was active and logged on)
- After the update when launching a new Report, the report would open inside a new instance of Excel
- The Controller link (inside this second session of Excel) tries to logon with us XYZ a second time, which triggers the error message.
Environment
End user's client machine has Microsoft Excel 2003 installed, with service pack 3 applied, plus a Microsoft Security Update for Excel 2003 (for example KB959995) has been automatically applied that same day.
Resolving The Problem
Workarounds:
Method #1 - Close Microsoft Excel in between using 'Reports - Run'
Method #2 - Instead of using the main 'Controller' program interface to run your reports from, use Excel instead:
- Launch Excel
- Logon to Controller using 'Controller - Logon'
- Click 'Reports - Open'
- Use this interface to select/run your report.
Solution:
Reboot client device (for example Windows XP desktop PC) where Controller device is running, to allow Excel hotfix to finish installing.
Related Information
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Document Information
Modified date:
15 June 2018
UID
swg21390025