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IBM Tivoli Composite Application Manager for Transactions Transaction Tracking 7.4 Fix Pack 1 README Tivoli Composite Application Manager for Transactions 7.4.0.1 7.4.0.0-TIV-CAMTT-FP0001 Readme

Fix Readme


Abstract

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Content

Readme file for: 7.4.0.0-TIV-CAMTT-FP0001
Product/Component Release: 7.4.0.1
Update Name: 7.4.0.0-TIV-CAMTT-FP0001
Fix ID: 7.4.0.0-TIV-CAMTT-AIX-FP0001, 7.4.0.0-TIV-CAMTT-LINUX-FP0001, 7.4.0.0-TIV-CAMTT-SOLARIS-FP0001, 7.4.0.0-TIV-CAMTT-WINDOWS-FP0001
Publication Date: 30 Jul 2015
Last modified date: 30 Jul 2015

Download location

To download this update, you must first login to IBM FixCentral. Once logged in, you may select from the individual download packages.
http://www.ibm.com/support/fixcentral/

Below is a list of components, platforms, and file names that apply to this Readme file.

Fix Download for AIX

Product/Component Name: Platform: Fix:
Tivoli Composite Application Manager for Transactions AIX
7.4.0.0-TIV-CAMTT-AIX-FP0001

Fix Download for Linux

Product/Component Name: Platform: Fix:
Tivoli Composite Application Manager for Transactions Linux
7.4.0.0-TIV-CAMTT-LINUX-FP0001

Fix Download for Solaris

Product/Component Name: Platform: Fix:
Tivoli Composite Application Manager for Transactions Solaris
7.4.0.0-TIV-CAMTT-SOLARIS-FP0001

Fix Download for Windows

Product/Component Name: Platform: Fix:
Tivoli Composite Application Manager for Transactions Windows
7.4.0.0-TIV-CAMTT-WINDOWS-FP0001

Prerequisites and co-requisites

This upgrade for ITCAM for Transactions Transaction Tracking supersedes 7.4.0.0 IF1, 7.4.0.0 IF5, 7.4.0.0 IF9, 7.4.0.0 IF15, 7.4.0.0 IF19 and 7.4.0.0 IF20 may be applied to the following base versions.

  • 7.3.0.1
  • 7.4.0.0
  • 7.4.0.0-IF01
  • 7.4.0.0-IF05
  • 7.4.0.0-IF09
  • 7.4.0.0-IF15
  • 7.4.0.0-IF19
  • 7.4.0.0-IF20
Note: Supported base versions include interim fixes applied to any of the above release levels.
This fix pack is also available as a refresh pack. Users can perform a base installation from a CD image at the FP0001 maintenance level. The base install image is available from Passport Advantage:
  • CN6AGML - ITCAM for Transactions V7.4.0.1 : Quick Start Guide and other Documentation
  • CN6AWML - ITCAM for Transactions V7.4.0.1 : Transaction Tracking - AIX
  • CN6AXML - ITCAM for Transactions V7.4.0.1 : Transaction Tracking - Windows
  • CN6AYML - ITCAM for Transactions V7.4.0.1 : Transaction Tracking - Solaris
  • CN6AZML - ITCAM for Transactions V7.4.0.1 : Transaction Tracking - Linux
  • CN6B0ML - ITCAM for Transactions V7.4.0.1 : Transaction Tracking - Language Support

For up-to-date ITCAM for Transactions v7.4 software prerequisites, please visit:
Prerequisites for ITCAM for Transactions V7.4

For additional download packages or ITM support information, visit the ITM support portal at:
https://www-947.ibm.com/support/entry/portal/product/tivoli/tivoli_monitoring_v6?productContext=1336534894

Known issues

  • INVESTIGATE CRTV:APPLICATION COLUMN

    Problem Description
    "crtv:Application" column in TEP workspace is not translated
    Root cause
    Translation properties not provided
    Workaround
    None.
  • TT DENORMALISED TO TABLES NOT SHOWING ALL RESULTS

    Problem Description
    Aggregate Metrics or Interaction Metrics, results are showing less rows than expected.
    Workaround
    None.
  • MQ NODES FOR MB DATAFLOWENGINE DISAPPEAR UNDER HEAVY LOAD

    Problem Description
    MQ Nodes for MB DataFlowEngine disappear under heavy load.
    Root cause
    Sometimes the OUTBOUND_FINISHED events for the DataFlowEngine and the STARTED_INBOUND events for the DataFlowEngine will disappear
    Workaround
    None.
  • NO DESCRIPTION FOR SUMMARIZATION COLUMNS

    Problem Description
    There are no descriptions for summarization columns
    Root cause
    Translation properties are not provided
    Workaround
    None.
  • CONCATENATION ISSUE ON STRING "Transaction Reporter Table"

    Problem Description
    The flyover string "Transaction Reporter Table" in ITM tool bar has concatenation problem in translation of pt_BR
    Workaround
    None.
  • FLYOVERS ARE MISSING TRANSACTION REPORTER CONFIGURATION PANEL

    Problem Description
    The flyovers are missing in "Transaction Report Configuration" panel
    Workaround
    None.
  • BASELINE CALCULATED WRONG AFTER REPORTER RESTART

    Problem Description
    Baseline and metrics values are incorrect in the sqlite database files after reporter restart.
    Root cause
    Incorrect assignment of aggregate ID on restart.
    Workaround
    None.
  • UNEXPECTED BASELINEMAXIMUMINITIALTIME VALUE ON WINDOWS

    Problem Description
    Baseline Maximum Initial Time metric value appears to have rounding issues.
    Workaround
    None.
  • TO FLEXIBLE TABLE TOPOLOGY SHOWS REMOTE NODE USING SOLID NODE ICON

    Problem Description
    TO flexible context topology shows remote note using solid node icon
    Workaround
    None.
  • TO UPDATE TOOL IS NOT OUTPUTTING ITS LOGS

    Problem Description
    TO update tool logs are not in expected directory
    Workaround
    None.
  • MISSING WMB NODE WHEN PSEUDO NODES ARE DISABLED

    Problem Description
    WMB node is missing when pseudo nodes are disabled
    Root cause
    When KK3UserExit is configured to disable pseudo nodes, no WMB node shows up in the Transaction Reporter because the STARTED and FINISHED events are not sent.
    Workaround
    None.

Known limitations

There are no known limitations.

Installation information

For Windows installation, if you encounter the message "Another version of this product is already installed" follow the instructions in the following support document to diagnose and resolve the problem. Note that although this technote refers to ITM, the diagnosing and resolving steps are applicable to ITCAM for Transactions Transaction Tracking.
https://www-01.ibm.com/support/docview.wss?uid=swg21587068

Prior to installation

Check and be aware of all releases of ITCAM for Transactions:
https://www.ibm.com/developerworks/community/wikis/home?lang=en#!/wiki/Tivoli%20Composite%20Application%20Manager/page/ITCAM%20for%20Transactions

This maintenance package is applied directly to the Tivoli Enterprise Management Agents (TEMAs). This package also includes required updates to the following ITM components:

  • Tivoli Enterprise Management Servers (TEMS) in the ITM infrastructure, including any Remote TEMS or fail over TEMS configurations.
  • Tivoli Enterprise Portal Server (TEPS).

You can install a TT agent either on a computer by itself or on a computer with an installed TEPS, TEMS, and/or portal. If you install a TT agent on a computer where the TEPS, TEMS and portal are already installed, the installer automatically stops the ITM agents and infrastructure (including TEMS and TEPS) running locally. If you install the TT agents on a computer by themselves, the ITM agents and infrastructure do not need to be stopped.

Installing

For latest information on installation, please visit:
https://www-01.ibm.com/support/knowledgecenter/SS5MD2_7.4.0.1/com.ibm.itcamt.doc/tt/dita/concept/kto_tools_in.html

Installing Transaction Tracking
This maintenance package is applied directly to the Tivoli Enterprise Management Agent (TEMA).

On Windows systems, extract the files from the archive and double-click WINDOWS\setup.exe. Follow the prompts to install the update.

On UNIX systems, extract the installer from the archive using the tar -xvf <filename.tar> command. Then, execute the installer using the ./install.sh command. Follow the prompts to install the update.

For more information consult the following online documentation:
Installing Transaction Tracking on Windows systems
Installing Transaction Tracking on Unix systems


Installing application support for TEPS/TEMS
In addition to installing the Transaction Reporter and Aggregation agents, you must install support files for the IBM Tivoli Monitoring components that are used by Transaction Tracking. You can choose to install application support on all components at one time, or you can install the application support on components separately. If installing components separately, the following order is recommended:

  1. Tivoli Enterprise Monitoring Server
  2. Tivoli Enterprise Portal Server
  3. Tivoli Enterprise Portal Desktop Client
  4. Tivoli Enterprise Portal Server Browser client (for Linux and UNIX Only)

The procedure for installing agent-specific application support on the components is similar to installing the monitoring agent. The main difference is to select the application support components required.

Note: When installing application support any ITM components on the current machine is automatically stopped, including any TEMS or TEPS. Follow the Starting and stopping servers and agents guide to manually stop ITM agents and infrastructure. You should warn other users before beginning the installation.

For step by step application support installation information refer to the documentation:
Installing support files



Performing the necessary tasks after installation

A successful installation sets the TT version to 7.4.0.1. Ensure that the version of the Transaction Tracking agents in the MTEMS is '07.40.01.00'.

On Windows the installation logs are written to the following directory:
ITM\InstallITM\

On Unix the installation logs are written to the following directory:
ITM/logs/

For latest information on configuration, please visit:
https://www-01.ibm.com/support/knowledgecenter/SS5MD2_7.4.0.1/com.ibm.itcamt.doc/tt/dita/concept/kto_tools_config.html

Troubleshooting installation problems from the Support site

For latest information on troubleshooting, please visit:
https://www-01.ibm.com/support/knowledgecenter/SS5MD2_7.4.0.1/com.ibm.itcamt.doc/tt/dita/tsg/concept/kto_ts_oview.html

Uninstalling if necessary

For latest information on uninstallation, please visit:
https://www-01.ibm.com/support/knowledgecenter/SS5MD2_7.4.0.1/com.ibm.itcamt.doc/tt/dita/concept/kto_tools_un.html

Additional information

The Secure Hash Algorithm 1 (SHA1) checksum of the images are as follows:
SHA1(7.4.0.0-TIV-CAMTT-AIX-FP0001.tar)= 32982aa3539489a9e153b36003a4bf0bae4112f2
SHA1(7.4.0.0-TIV-CAMTT-Linux-FP0001.tar)= d7afb4e6f6406941a23e85cc3c2f4620eaa09fb9
SHA1(7.4.0.0-TIV-CAMTT-Solaris-FP0001.tar)= f16879f7d39df64253ee54541201bb5d63057c4e
SHA1(7.4.0.0-TIV-CAMTT-Windows-FP0001.zip)= 065f7c65d2192748a543099a4df81446558d671a

New Features

The following new features are included in ITCAM for Transactions - Transaction Tracking 7.4 Fixpack 1:

  • Enhancements to Transaction Tracking component (Transaction Reporter and Transaction Collector).
  • Calculation of 'network' time. Network time is an approximation of the time a transaction took to traverse (request plus response) the network between two nodes. The metric is calculated as the difference between the sub-transaction time (time between a request and response to a child node from a parent node) and the child time (time for the child transaction to run).
  • Monitoring and alert on all transaction instances. This enhancements means alerts can be generated in the Transaction Collector (TU) agent in addition to generating alerts in the Transaction Reporter (TO) agent.
  • Monitoring and alert on 'incomplete' transactions. Detect and alert (after a user specified time-out period) when a user transaction starts but does not end.

List of fixes

A) APAR Content:
IV48451 Update TT installation guide for zOS TEMS support for TU and TO
IV48901 PUTFORCACHE error when the sum of string lengths for all the destination componentname to the same server is greater than 256 characters
IV54312 TO ignoring comparator for GRP_LVL
IV55119 TO incorrect attribute definition for short integer attributes
IV55309 RDF not generated properly when transaction definition name is reused
IV55733 TO/TU support files cause atr name conflict warnings in ITM logs
IV61172 IF0015 TU and TO have incorrect version info resulting in application support mismatch error
IV63214 TTAPI crash in Tomcat when connection to the TU
IV64568 Error when linking to historical transaction instances workspace
IV65549 Expose TTAPI queue size setting in the TH proxy configuration
IV66334 TO spends too long reading metadata.xml
IV69653 Unable to remote deploy TU agent due to incorrect version information in agent file
IV70870 KK3 output error: WMB nodes fails to stitch with WMQ nodes if destination list is used
IV71905 Can't find KD4 Header for IIB Integration Service
IV75516 KK3 Agent re-throwing internal exceptions, causing Message Broker flows to terminate

From superseded fixes:

IV51833 TO data always unavailable in agent-less application

B) Additional Non APAR Defects:
N/A

Document change history


Version Date Description of change
1.0 30 July 2015 Initial Version
1.1 31 July 2015 Clean up Known issues


















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Document Information

Modified date:
31 July 2015

UID

isg400002246