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ANR2969E Database restore terminated. DB2 sqlcode: -2033. DB2 sqlerrmc: 168.

Troubleshooting


Problem

Server database restore fails with the following message after volume is mounted for restore : ANR2969E Database restore terminated. DB2 sqlcode: -2033. DB2 sqlerrmc: 168.

Symptom

You may see the following errors in db2diag.log:

    2014-06-29-11.33.50.272099-360 E506980A347 LEVEL: Error
    PID : 8978570 TID : 1 PROC : db2vend
    INSTANCE: tsmadmin NODE : 000
    EDUID : 1
    FUNCTION: DB2 UDB, database utilities, sqluvint, probe:320
    DATA #1 : TSM RC, PD_DB2_TYPE_TSM_RC, 4 bytes
    TSM RC=0x000000A8=168 -- see TSM API Reference for meaning.

    2014-06-29-11.33.50.273361-360 I507328A748 LEVEL: Error
    PID : 7143462 TID : 71706 PROC : db2sysc 0
    INSTANCE: tsmadmin NODE : 000
    EDUID : 71706 EDUNAME: db2med.3086.0 (TSMDB1) 0
    FUNCTION: DB2 UDB, database utilities, sqluMapVend2MediaRCWithLog,
    probe:655
    DATA #1 : String, 135 bytes
    Vendor error: rc = 11 returned from function sqluvint.
    Return_code structure from vendor library
    /home/tsmadmin/sqllib/adsm/libtsm.a:

    2014-06-29-11.33.50.273758-360 I508077A374 LEVEL: Error
    PID : 7143462 TID : 71706 PROC : db2sysc 0
    INSTANCE: tsmadmin NODE : 000
    EDUID : 71706 EDUNAME: db2med.3086.0 (TSMDB1) 0
    FUNCTION: DB2 UDB, database utilities, sqluMapVend2MediaRCWithLog,
    probe:695
    MESSAGE : Error in vendor support code at line: 320 rc: 168

    2014-06-29-11.33.50.275235-360 E509640A545 LEVEL: Error
    PID : 7143462 TID : 3086 PROC : db2sysc 0
    INSTANCE: tsmadmin NODE : 000 DB : TSMDB1
    APPHDL : 0-8 APPID: *LOCAL.tsmadmin.140629173351
    AUTHID : TSMADMIN
    EDUID : 3086 EDUNAME: db2agent (TSMDB1) 0
    FUNCTION: DB2 UDB, database utilities, sqludMRResponse, probe:869
    MESSAGE : SQL2033N An error occurred while accessing T

Cause

RC 168 means the password was not set correctly for the API. This can occur if one fails to prepare the server database for backup or if dsmapipw was not successfully run.

Resolving The Problem

Run all steps in "Preparing the database manager for database backup" section of installation guide.

Running dsmapipw is part of this process and will set the password for the TSMDBMGR node, which will be used for the database backup.


For details on preparing the environment, refer to the server documentation:
Preparing the Database Manager for database backup

Related Information

[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Server","Platform":[{"code":"PF002","label":"AIX"}],"Version":"Version Independent","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Product Synonym

TSM

Document Information

Modified date:
23 June 2018

UID

swg21679072