Distance Learning hands-on Labs
IBM Rational Developer for i

Maintain an IBM i application using

Remote System Explorer

Getting started with RSE

Create a connection to IBM i and work with objects

Lab Exercises Lab01
Contents

LAB 1............ MAINTAIN AN IBM I APPLICATION USING REMOTE SYSTEM EXPLORER (RSE) GETTING
STARTED 9

1.1.................................................................................................................................................. OVERVIEW 9

1.2.................................................................................................................................................. STARTING RDI AND THE REMOTE SYSTEM EXPLORE 10

1.3................................................................................................................................................. WORKING WITH THE REMOTE SYSTEM EXPLORER PERSPECTIVE 12

1.4.................................................................................................................................................. CONFIGURING A CONNECTION TO IBM I AND CONNECTING TO A SERVER 13

1.5................................................................................................................................................. VIEWING AND ACCESSING OBJECTS IN THE REMOTE SYSTEM EXPLORER 21
Lab 1 Maintain an IBM i application using Remote System Explorer (RSE) getting started

1.1 Overview
This Lab is the first in a series of Labs that introduce Rational Developer for i (RDi). The Labs show how to edit, compile, debug and sample IBM i application. The Labs also show how to use the RDi Screen designer, and Application Diagram Viewer.
The Labs02 to 08 depend on the instructions in this Lab01. You should work through this Lab first to establish a connection to an IBM i server, then it is up to you whether you work on these Lab in sequence or pick one of the Labs that you are most interested.
This series of Labs 02-08 teaches you how to maintain an IBM i application written in ILE RPG using the Remote System Explorer.

Learning objectives
• Start the product and open the Remote System Explorer perspective
• Use tools and views in this perspective to connect to an IBM® i system
• Work with native IBM i objects using the RSE.

Skill level
Introductory

Audience
IBM i developer

System requirements
• IBM Rational® Developer for i, V7.5 and all software updates through the IBM Installation Manager.
• IBM i V5R3, V5R4, or V6R1

Prerequisites
• Basic Microsoft Windows operations such as working with the desktop and basic mouse operations such as opening folders and performing drag-and-drop operations
• It will also help if you understand DDS and ILE RPG.
This tutorial is divided into a number of modules, each with its own learning objectives. You can choose to skip the modules on Edit and Compile. You can go directly to the Debug module if you are only interested in that part. Each module contains several lessons that should be completed in order for the tutorial to work as shown in this script.

Expected results
Upon completion of this tutorial you will know how to connect to an IBM i system from the Remote System Explorer. You will also know how to work with IBM i objects using the Remote System Explorer.

Conventions used in this tutorial
• Bold font for user interface controls
• Mono-spaced font for user input and code blocks
• Italic font for variable names and glossary terms.
Learning objectives
- Start the product
- Set the default workspace
- Create a connection to an IBM i server
- Connect to an IBM i server
- Add a library to your library list
- View libraries in your job’s library list from the Remote Systems view
- Find a source physical file in your library

1.2 Starting Rdi and the Remote System Explore

This module teaches you about the workbench, the workspace, a perspective and specifically the Remote System Explorer perspective.

1.2.1 Starting the product

First you must start the product. Follow these steps to start the product:

1. Click Start on the task bar of your desktop.

2. Select Programs > IBM Software Delivery Platform > IBM Rational Developer for i > IBM Rational Developer for i

If you are working with the RDI SOA version of the product you will see slightly different product names.

A dialog will appear. Here you specify the directory of the workspace where your projects and other resources such as folders, subfolders and files that you are developing in the workbench will reside.
3. (Optional) Change the field in this dialog and use a unique directory name, for example, RSELABxx (where xx is a unique number). Don’t worry about the directory path it might vary from one workstation to the other.

4. Click OK to open the workbench.

5. Click Select a topic to view a list of available information. Select any of the entries and explore the topic. When you are done, click the X next to the Welcome tab to close the Welcome page.
Closing the Welcome page will take you to the Remote System Explorer perspective.

Notice that each image on the Welcome page will lead you to additional information about the product.

Tip
To open the Welcome page again, select Help > Welcome.

6. Click the maximize button to maximize the workbench.

You have started the product and opened the workbench. The workbench refers to the desktop development environment. The workbench aims to achieve seamless tool integration and controlled openness by providing a common paradigm for the creation, management, and navigation of workbench resources. Each workbench window contains one or more views and an editor.

1.3 Working with the Remote System Explorer perspective

In the Remote System Explorer (RSE) perspective,

1. If you are not sure which perspective is open at the moment, you can check for the name of the perspective in the workbench title bar.
1.3.1 What is a perspective?
A perspective defines the initial set and layout of views in the workbench window. Within the window, each perspective shares the same set of editors. Each perspective provides a set of capabilities aimed at accomplishing a specific type of task or working with specific types of resources. For example, the Java™ perspective combines views that you would commonly use while editing Java source files, while the Debug perspective contains views that you would use while debugging a program. Perspectives contain views and editors and control what appears in certain menus and tool bars.

If you see a different perspective, not the **Remote System Explorer** open in the workbench or no perspective:

2. Click **Window > Open Perspective > Remote System Explorer** from the workbench menu.

The Remote System Explorer perspective opens.

You work in the Remote System Explorer perspective in the workbench. This perspective is for IBM i developers. You can display the connections that you have already configured, create a new connection, connect to and disconnect from the connections that you have defined, work with IBM i files, commands, jobs, and integrated file system files.

This perspective will be active when you start the product with a new workspace. If you had used the workspace before then, the workbench would come up with the perspective that you last opened. You will learn more about the Remote System Explorer perspective in the coming exercises as this is where you launch the IBM i developer tools and use the views from the workbench.

1.4 Configuring a connection to IBM i and connecting to a server
This module teaches you how to create a connection to an IBM i server, find a library in your library list, select objects from a library and finally open a member in the Remote Systems LPEX Editor. You also learn about several views such as the Remote Systems view, IBM i Table view, and the Outline view.

1.4.1 Configuring a connection to an IBM i server

When you first open the Remote System Explorer, you are not connected to any system except your local hard drive on your workstation. To connect to a remote system, you need to define a connection. When you define a connection, you specify the name or IP address of the remote system and you give your connection a unique name that acts as a label in your workspace so that you can easily connect and disconnect. When you connect to the remote system, the workbench prompts you for your user ID and password on that host.

All connections, filters, and filter pools belong to a parent profile. Filters are described in a later lesson. Profiles are discussed when you create your first connection.

Remember you have already opened the Remote System Explorer perspective in the previous module. In the Remote Systems view,

1. Click the plus sign + to expand **New Connection** if it is not already expanded to show the various remote systems types you can connect to through the Remote System Explorer.

**Troubleshooting**

If you don’t have a New connection node, use the new connection button to create the connection.

To connect to an IBM i remote server
3. Double-click **IBM i** to configure a connection to a remote system. The Remote IBM i System Connection page opens.

```
Parent profile: iweiss
Host name: s40Ga
Connection name: s40Ga
Description: 
```

Here you specify the information for your connection. The **Parent profile** defaults to the name of the workstation. Your profile will be different from the one shown here.

The cursor on this page is positioned in the **Host name** field.

4. In the **Host name** field, type the IP address or the name of your host system. The Connection name is automatically filled with the host name. Leave it this way. This name displays in your Remote Systems view and must be unique to the profile.
5. Leave the **Parent profile** default value. You don’t need to change it.

6. Leave the **Verify host name** check box selected.

7. Click **Finish** to define your system.

1.4.2 The RSE subsystems

After you configure a connection to an IBM i system, you can easily connect and expand your new connection to show the subsystems. Subsystems are pre-defined filters grouping the various types of remote resources that can be explored in the remote system. There are four subsystems.

- **Objects**
  A PDM-like group, allowing access to libraries, objects and members.

- **Commands**
  Contains predefined commands and allows you to create command sets each of which contain one or more often used commands. When run, all commands in a command set are sent to the remote system and executed, and the results are displayed in the Commands log view.

- **Jobs**
  Allow you to see various jobs, subset by job attributes, and to perform a number of operations on those jobs.

- **IFS Files**
  Allow you to explore folders and files in the Integrated File System of the remote IBM i system.

1.4.3 Connecting to an IBM i system

To connect to the **s400a** system:
1. Click on the plus sign + to expand your s400a connection.

In the Remote Systems view, your new connection is expanded to reveal your subsystems. The **Objects** subsystem is the subsystem you will use most often! It is very similar to PDM, in that it allows you to access objects in the QSYS file system, and perform actions on those objects.

2. Click on the plus sign + to expand the **Objects** subsystem.

Notice the first three entries under the **Objects** subsystem are named after the PDM options, because they have similar capabilities:

- **Work with libraries** (similar to WRKLIBPDM)
- **Work with objects** (similar to WRKOBJPDM)
- **Work with members** (similar to WRKMBRPDM)

In addition there are entries for working with library lists and user libraries:

- **Library list** (to simulate PDM’s WRKLIBPDM you can start with the pre-defined Library list filter, that when expanded lists all libraries in your library list.)
- **User libraries** (allows you to work with all user libraries you can access on that server.)

You also have more entries to work with under the connection itself and you can see from these entries that Remote System Explorer goes well beyond PDM! It allows you to explore IBM i jobs and commands and the IFS file system.
Now let’s work with a library in your library list and add the library that you’ll be using in this tutorial:

3. Right-click **Objects** and click **Properties** on the pop-up menu. The **Properties for Objects** dialog displays.
4. Select **Initial Library List** on the left pane.
5. In the **Library** field, type RSELABxx where **XX** is your team number.
6. Click **Add**.
7. Click **OK**.

This will add the library RSELABxx to your library list every time you open this connection. You can use the properties of any of the subsystems to set connection information such as adding a library to the library list.

**Tip**
You can also change your library list using the pop-up menu items **Add Library List Entry** or **Change Current Library** on the **Library list** folder in the Objects subsystem. These changes are only valid until you disconnect.
8. Expand the **Library list** folder.

9. Now the connection will be activated and you will be prompted for user ID and password. By default, the user ID field contains the user name that you used to log on to the workstation.

10. Enter your user ID and password. Remember to enter your team number instead of **XX**.

11. Select the **Save user ID** check box.

12. Select the **Save password** check box.

13. Click **OK**.

Back in the Remote Systems view, you will see the libraries in your job’s library list.
Notice that the s400a folder now has a small green arrow in the icon to indicate that it is an active connection.

For each library, you can right-click and select from a number of actions. For example, there is an action to create a new source file within the selected library. Common actions like delete, move, copy, etc. are valid for all kinds of objects.

You have connected to an IBM i system and used the Remote Systems view to view libraries in the library list.

1.5 **Viewing and accessing objects in the Remote System Explorer**

Now you are ready to view and access objects in your library RSELABxx.

1.5.1 **Using the RSE view**

To view and access an object:

1. Expand library RSELABxx by clicking the **plus sign** + beside it. You will see all objects in this library appear in the Remote Systems view. For each object you can right-click and select from a number of actions. The list of actions depends on the object selected and whether you selected one or multiple objects. For example, for a source file the pop-up menu has an action to create a new member within the selected file.

2. Scroll-down through the files in the Remote Systems view until you find QDDSSRC source file and expand it.

Now you can see and access the members in these two source files. For each member you can right-click and select from a number of actions. The exact list of actions depends on whether the member is a data file or source file and whether you select one or multiple members. For a RPG source member, the pop-up menu actions include:

- open with
- browse with
- verify
- compile

1.5.2 Using the Object Table view

Before you go ahead and work with these members, let’s see the members in the Object Table view as well because that is similar to the view you are used to from PDM. You use this view to display a list of items, for example members or objects, in a table format similar to PDM. You can also perform actions against these items such as editing and compiling.
1. Right-click the QDDSSRC file and then click **Show in Table** on the pop-up menu. The Object Table view takes the selected object in the Remote Systems view as input, and displays the contents in the table. For source physical files, this step displays the members inside, their names, types, attributes, and text descriptions.

The top of the Object Table view contains a lock icon that controls the correlation between the Remote Systems view and the Object Table view. If the lock is disabled then whenever you click an object or library in the Remote Systems view, the associated contents of that item automatically populate the Object Table view. If the lock is enabled then when you click on various items in the Remote Systems view, this view does not change the content of the Object Table view. To enable or disable the lock, you can click it once to change its state.
You can click on the columns heading to sort the view by column.

_2. In the Object Table view toolbar make sure the **lock/unlock button** is in the unlock position. Leave the mouse pointer over the tool button for a second or two to display the flyover help. That way you can check if the view is locked or unlocked.

This means now the table will automatically be updated when a different object is selected in the Remote Systems view. This is a shortcut to open the pop-up menu for an object in the Remote Systems view and to select Show in Table.

1.5.3 Customizing the Object Table view

You can also modify which specific columns you want to see in the Object Table view.

To modify the Object Table properties:

Click **Window > Preferences** from the workbench menu.

The Preferences Window opens.

_3. In the left pane of the Preferences window, expand **Remote Systems**.
_4. Expand **IBM i** under Remote Systems.
_5. Click **Table View** under IBM i.
_6. In the right pane of the Preferences window, select **Last modified** in the **Available columns** list.
_7. Click the **Add** button.
_8. Click **OK**.
Now, let’s update the Object Table view.

9. Click the down arrow on the Object Table view title bar

10. Click **Show columns > Customized** in the pop-up menu. Now you’ll see the extra column that you’ve added.

You can also sort the objects in the object Table view by column.

11. To sort the objects in ascending order by Last modified, click on the heading.

12. If you click the heading the second time, it will sort it in descending order.

Back in the Remote Systems view,

13. Select QRPGLESRC.

The table shows the members in QRPGLESRC.
Besides the Object Table view, there are also a Field Table view and a Data Table view. For a selected data file, the Field Table view shows which fields are defined in the file and their properties. The Data Table view displays the data contained in the file.

1.5.4 Using the other Table views

To display the other table views:

1. In the Remote Systems view, right-click PRJMST and select Show in Table > Fields.

The Field Table view opens.
To display the Data Table view:

14. In the Remote Systems view, right-click PRJMST again, select **Show in Table > Data**. The Data Table view opens.

Now you are ready to use the Remote Systems LPEX Editor to edit the source members.

**Congratulations!**

You have successfully completed the getting started with the RDi Lab

Feel free to exploit the other Labs 02 – 08 that are available, the next logical Lab to go thru is the 'Edit a source member and work with the LPEX editor, LAB02.

More information and material can be found at our RPG CAFE


Look for the RDi hub
Enjoy Rational Developer for IBM i!
Notices

© Copyright IBM Corporation 1992, 2009 All rights reserved.

U.S. Government Users Restricted Rights - Use, duplication or disclosure restricted by GSA ADP Schedule Contract with IBM Corp.

This information was developed for products and services offered in the U.S.A. IBM may not offer the products, services, or features discussed in this documentation in other countries. Consult your local IBM representative for information on the products and services currently available in your area. Any reference to an IBM product, program, or service is not intended to state or imply that only that IBM product, program, or service may be used. Any functionally equivalent product, program, or service that does not infringe any IBM intellectual property right may be used instead. However, it is the user’s responsibility to evaluate and verify the operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter described in this documentation. The furnishing of this documentation does not give you any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing IBM Corporation
North Castle Drive
Armonk, NY 10504-1785 U.S.A.

For license inquiries regarding double-byte (DBCS) information, contact the IBM Intellectual Property Department in your country or send inquiries, in writing, to:

IBM World Trade Asia Corporation Licensing
2-31 Roppongi 3-chome, Minato-ku Tokyo
106, Japan

The following paragraph does not apply to the United Kingdom or any other country where such provisions are inconsistent with local law: INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS PUBLICATION AS IS WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OR CONDITIONS OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or implied warranties in certain transactions, therefore, this statement may not apply to you.

This information could include technical inaccuracies or typographical errors. Changes are periodically made to the information herein; these changes will be incorporated in new editions of the publication. IBM may make improvements and/or changes in the product(s) and/or the program(s) described in this publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for convenience only and do not in any manner serve as an endorsement of those Web sites. The materials at those Web sites are not part of the materials for this IBM product and use of those Web sites is at your own risk.

Licensees of this program who wish to have information about it for the purpose of enabling: (i) the exchange of information between independently created programs and other programs (including this one) and (ii) the mutual use of the information which has been exchanged, should contact:
Such information may be available, subject to appropriate terms and conditions, including in some cases, payment of a fee.

The licensed program described in this documentation and all licensed material available for it are provided by IBM under terms of the IBM Customer Agreement, IBM International Program License Agreement or any equivalent agreement between us.

Any performance data contained herein was determined in a controlled environment. Therefore, the results obtained in other operating environments may vary significantly. Some measurements may have been made on development-level systems and there is no guarantee that these measurements will be the same on generally available systems. Furthermore, some measurements may have been estimated through extrapolation. Actual results may vary. Users of this document should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of those products, their published announcements or other publicly available sources. IBM has not tested those products and cannot confirm the accuracy of performance, compatibility or any other claims related to non-IBM products. Questions on the capabilities of non-IBM products should be addressed to the suppliers of those products.

All statements regarding IBM’s future direction or intent are subject to change or withdrawal without notice, and represent goals and objectives only.

**Copyright license**

This information contains sample application programs in source language, which illustrates programming techniques on various operating platforms. You may copy, modify, and distribute these sample programs in any form without payment to IBM, for the purposes of developing, using, marketing or distributing application programs conforming to the application programming interface for the operating platform for which the sample programs are written. These examples have not been thoroughly tested under all conditions. IBM, therefore, cannot guarantee or imply reliability, serviceability, or function of these programs.

Each copy or any portion of these sample programs or any derivative work, must include a copyright notice as follows:

© (your company name) (year). Portions of this code are derived from IBM Corp. Sample Programs. ©Copyright IBM Corp. 1992, 2009. All rights reserved

**Trademarks and service marks**

The following terms are trademarks or registered trademarks of International Business Machines Corporation in the United States, other countries, or both.

- i5/OS
- IBM
- OS/400
- Rational
- WebSphere

Microsoft, Windows, and the Windows logo are trademarks of Microsoft Corporation in the United States, other countries, or both.
Other company, product or service names may be trademarks or service marks of others.