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You may know that Eclipse is a framework meant for building other tools. You may
also know that you can build your own plug-ins for Eclipse. But did you know that
Eclipse comes with seven plug-in templates to get you started? This tutorial gives
you a start-to-finish look at building a plug-in using the Hello World template, then
introduces you to the other templates.

Section 1. Start here

Should | take this tutorial?

In this tutorial, you will learn how to build, package, and deploy different types of
Eclipse plug-ins using the seven plug-in templates provided with Eclipse. Using
these templates helps you by generating many of the necessary plug-in files and
configurations, and will reduce your learning curve by providing simple, customized
working examples.

What is this tutorial about?

This tutorial introduces you to Eclipse plug-in development. It walks you through the
process of developing, packaging, and deploying a plug-in developed from the
seven built-in plug-in templates. It discusses in detail each of the following plug-in
templates to give you a broad understanding of the types of options available:
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» Hello World

* Popup Menu

* Property Page

* View

» Perspective Extension
 Editor

* Multi-page Editor

You can begin writing Eclipse plug-ins by hand from scratch. However, using the
templates can help you:

» Set up basic plug-in project structure
* Reduce coding
* Reduce your learning curve

Plug-in projects have a specific structure. Using the Plug-in Project wizard and
templates helps to set up the required structure. In addition, it generates many of the
necessary files and configurations. This project structure requires a plugin.xml file at
the root of the project. Consider this file as a deployment descriptor for an Eclipse
plug-in. It contains information about the plug-in's classpath, other plug-ins it
depends on and which extension points the plug-in integrates into. In addition, the
project must contain a class that extends

org. eclipse. ui.plugin. Abstract U Pl ugi n. This class will be described in
further detail later in this tutorial. And as with all Java™ technology projects, it must
contain a source folder and output folder.

Using templates can significantly reduce the amount of typing. They generate many
of the classes you need to get started and provide a simple implementation, usually
a message dialog, to show you what an implementation might look like. The plug-in
templates also update the plugin.xml file to include extension-points and required
libraries.

The Eclipse platform itself has more than 1,900 classes and interfaces. Add the JDT,
PDE, and J2SE and there is a lot to learn. The plug-in templates can reduce the
learning curve and anxiety by providing simple, customized working examples in a
few minutes.

Prerequisites

To gain the most from this tutorial, you should have a good working knowledge of
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Eclipse. Before you start, make sure you have Eclipse downloaded and installed:
Eclipse SDK V3.0.2.

Basic knowledge of Java is also helpful.

Section 2. Eclipse overview

Background

As described on the Eclipse Web site, Eclipse is a universal tool platform, an open,
extensible, integrated development environment (IDE). Open and extensible are the
operative words in this description. All development efforts do not involve the same
types of applications, APIs, languages, or version control. So the Eclipse platform
was architected from the beginning to enable individuals and organizations to extend
the platform in any way they want using plug-ins. This is liberating since it enables
us as developers to customize Eclipse through existing plug-ins or create our own to
make ourselves productive.

Eclipse can boast of more than 850 commercial and open source plug-ins. These
support just about every aspect of development. The Eclipse Web site even hosts
many of its own popular plug-ins, including the new Web Tools Platform for
developing J2EE and Web applications.

The Resources section contains a list of sites where you can find commercial and
open source plug-ins.

Architecture

Eclipse itself has a layered architecture (see Figure 1), made up primarily of
plug-ins. The platform does have a small micro-kernel used to bootstrap the
plug-ins, but the rest of the platform is made up of plug-ins. This means anything
Eclipse does you can do with the custom plug-ins you develop.

When you install the Eclipse SDK, you are installing three components that comprise
the Eclipse project: the Eclipse Platform, Java Development Tools (JDT), and the
Plug-in Development Environment (PDE). Each of these can be extended and have
their own APIs. See Resources for links to each of the respective developer guides
and APlIs.

The focus of this tutorial is the tools found in the PDE, including the plug-in
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templates. Knowing how to use these tools will enable you to extend Eclipse to meet
your needs.

Figure 1 depicts the Eclipse Platform in the light gray. It is the foundation of Eclipse
and the only required component. It sits on top of the Java 2 Standard Edition
(J2SE) platform, allowing it to run on any operating system supported by the Java
platform. Layered on top of the J2SE is the Eclipse platform run time, which includes
the micro-kernel and the infrastructure for discovering and loading plug-ins. Until
recently, this infrastructure was proprietary to Eclipse. However, Eclipse is in the
process of switching to the standards-based OSGI Service Platform specification
designed for dynamic services.

Figure 1. Eclipse architecture
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The workspace acts as an abstract of the underlying file system. It is responsible for
managing resources, such as projects, folders, and files. Also included within the
workspace is the popular open source project: Apache Ant. The workbench is the
graphical user interface used to interact with the workspace and run time. It also
provides extensions for other visual plug-in integration. As you will read, SWT and
JFace, Eclipse uses its own widget tool kit.

The Workbench includes three major extensions: Help, Debug, and Team. Help
provides a mechanism for adding help to Eclipse's help system using HTML. Debug
provides a debugger infrastructure that can be extended to support any language.
Team is an extension for source code configuration management tools. It includes
an implementation for CVS.

Building Eclipse plug-ins using templates Trademarks
© Copyright IBM Corporation 2005. All rights reserved. Page 4 of 74


http://www.ibm.com/developerworks/ibm/trademarks/
http://www.ibm.com/legal/copytrade.shtml

ibm.com/developerWorks developerWorks®

As shown in Figure 1, the JDT sits on top of the Eclipse Platform. The platform
subproject provides an implementation for developing basic Java applications. It
includes Java compiling and debugging. It also provides tools for editing, packaging,
and unit-testing Java applications.

To make extending Eclipse easier, the SDK includes the PDE. The PDE includes the
tool necessary for developing, packaging, and deploying Eclipse plug-ins. Because
Eclipse is built on the J2SE, you need Java development tools to write plug-ins.
Therefore, the PDE is built upon the JDT.

SWT and JFace

When the Eclipse Platform was originally developed, the architects felt the existing
Java widget tool kits of Swing and Abstract Windows Toolkit (AWT) did not perform
well enough or have the desired platform-native look and feel, so they created their
own tool kit. This new widget tool kit and graphic library is the Standard Windows
Toolkit (SWT).

Don't worry if you don't have any knowledge or experience with SWT or JFace. You
won't need it to follow along. You will have to become familiar with both, however, as
you get deeper into plug-in development.

In a lot of ways, SWT combines the best concepts of Swing and AWT. Where
applicable, SWT uses native widgets of the underlying operating system much like
AWT does. This provides the advantages of performance and a native application
look and feel. Unfortunately, not all operating systems are created equal. So, rather
than go with a least-common-denominator approach and only expose widgets
common on all operating systems, SWT implements and renders its own version of
the widgets if not supported by the underlying operating system. This is similar to
how Swing implements all of its widgets.

To make SWT easier to use, a framework called JFace is layered on top of it. JFace
provides a higher-level model, but at the same time does not hide SWT.

NOTE: SWT and JFace are frameworks independent of the Eclipse Platform and
can be used as such to develop stand-alone desktop applications.

If you are familiar with Swing, the transition to SWT and JFace is a small learning
curve. See Resources for links to articles and books about SWT and JFace.

Plug-in Development Environment tools
The PDE contains the tools necessary for developing plug-ins to extend Eclipse.

You use these tools to develop, package, and deploy your plug-ins. These tools
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include the plug-in templates that are the focus of this tutorial. They also include
wizards, a Plug-in Development Perspective, views and special manifest editors.

The PDE includes seven wizards found in the Plug-in Development category of the
New dialog. In this tutorial, we will use the Plug-in Project for setting up the project
structure and running the first template, the Feature Project, for creating a plug-in
feature to ease deployment, and the Update Site Project for creating an internal or
external Web site for deployment.

Upon completing the Plug-in Project wizard, you will be prompted to switch to the
Plug-in Development Perspective if you have not done so already. This perspective
is helpful for developing plug-ins because it is similar to the Java Perspective, but
includes two additional views specific to plug-in development: Plug-ins and Error
Log. Additional PDE views can be found in the Show views dialog under the
categories PDE and PDE Runtime.

The Plug-ins view contains a list of plug-ins available in your current instance of
Eclipse. This view is helpful for archeology work. You can dig through other plug-ins,
especially their plugin.xml files, to learn how other plug-ins accomplished what you
want to accomplish. For example, you might ask how the Plug-ins view gets included
in the Plug-in Development perspective.

The Error Log view displays the contents of the Eclipse log file found in the
workspace's . met adat a directory. This can be helpful to diagnose problems your
new plug-in may be causing internal to the Eclipse platform.

Plug-ins require a manifest file with the name of plugin.xml. Later in this tutorial, you
will learn more about this file. To make it easier to modify this file, the PDE includes
a special multi-page editor called the Plug-in Manifest Editor (see Figure 2). It is
associated with the plugin.xml file.

Figure 2. Plug-in Manifest Editor

Building Eclipse plug-ins using templates Trademarks
© Copyright IBM Corporation 2005. All rights reserved. Page 6 of 74


http://www.ibm.com/developerworks/ibm/trademarks/
http://www.ibm.com/legal/copytrade.shtml

ibm.com/developerWorks

developerWorks®

-E'E-cl:um.il:um.b_lb:urial.templates PR

Overview

General Information

This section describes general infarmation about
this plug-in

ID; com.ibm, tutaorial, templates
Version: [1.0.0

Mame: |Templates Plug-n
Provider: [IBM

Class: | com.ibm, tutorial, terplz |

Browse...

Testing @j

You can test the plug-in by launching a second
{runtime) instance of the workbench:

ﬁ Launch a runtime workbench

ﬁ Launch a runtime warkbench in Debug
mode

Plug-in Content

The content of the plug-in is made up of four
sections:
_‘? Dependencies: lists all the plug-ins required
an this plug-in's dasspath to compile and run.

Runtime; lists the libraries that make up this
plug-in's runtime,

fiE]

_‘F Extensions: dedares contributions this plug-in

makes to the platform.
alf

i Extension Points: dedares new function
points this plug-n adds to the platform.

Deploying @
To deploy the plug-in:
1. Spedfy what needs to be packaged in the

deployable plug-in on the Build Configuration
page

2. Export the plug-n in a format suitable for
deployment using the Export Wizard

Owerview | Dependencies | Runtime | Extensions | Extension Paints i Build | plugin. xml | build. properties |

We will use this editor throughout this tutorial. We will primarily focus on the
Overview, Extensions, and plugin.xml pages.

The first page of the Plug-in Manifest Editor provides an overview of the plugin.xml
file. It includes general information about your plug-in. It also contains links to the
other pages from the Plug-in Content area. The Testing section provides an easy
means to run and debug plug-ins. A shortcut to the export wizard for packaging the
plug-in is provided in the Deploying section.

The Extension page can be used to run the plug-in templates on an existing plug-in
project. The plugin.xml page is a text editor for the entire contents of the plugin.xml

file.

The PDE also includes a large amount of documentation for extending the Eclipse
Platform, JDT, and PDE. They are integrated into Eclipse's regular help. They
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include developer guides and Javadoc.

Section 3. Create a plug-in with the Hello World template

Overview

In this section, we will learn how to write a plug-in that adds a menu and menu item
to the Eclipse main menu, and a button to the toolbar. We will use the Hello World
template as a starting point and modify the behavior to copy the active editor's
absolute file name to the operating system's clipboard. In addition, since this is the
first plug-in we are covering, we will walk through the process of developing an
Eclipse plug-in. So by the end of this section, you should know how to write, debug,
package, and deploy Eclipse plug-ins in general.

Building a plug-in
The process of creating a plug-in is not all that different from developing a regular
Java application with Eclipse:

1. Create Plug-in Project

2.  Create plug-in using template

Test and debug plug-in

W

Create a Feature Project
5. Package plug-in
6. Deploy plug-in

The first two steps can actually be done in a single step. The Plug-in Project wizard
iS one opportunity to create a plug-in from a template. This is how we will create the
plug-in from the Hello World template. Later in the tutorial, we will see how to create
a plug-in for an existing plug-in project.

Testing and debugging an Eclipse plug-in is rather fun. It is really not much different
from debugging or testing a regular Java application in Eclipse, except that when
you click the Run or Debug button, it launches another instance of Eclipse. Learning
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how to use the debugger in Eclipse is out of scope here. See Resources for a
debugging article if you are unfamiliar with debugging in Eclipse.

Ultimately, you will want to share your plug-in with your friends, co-workers, and
possibly the rest of the Eclipse community. To do that, you will want to create a
feature. A feature is a collection of one or more plug-ins and fragments. Features are
not required, but can make installation and managing your plug-in easier for your
users, and make packaging multiple plug-ins a breeze.

Packaging a plug-in or a collection of plug-ins as a feature follows the Eclipse export
model and is just like exporting a JAR or Javadoc. Once you have packaged your
plug-ins, you can deploy them as a zip file created from the packaging process or
make them available on an internal or external Web site using Update Site Project.

Default Hello World template plug-in behavior

The default behavior of the plug-in that results from starting with the Hello World
template is shown in Figure 3. The plug-in adds a main menu item to the Eclipse
main menu and a menu item under that. In addition, a button is added to the toolbar.

Figure 3. Hello World menu and toolbar button

= Resource - Eclipse Platform

File Edit Mavigate Search Project | Sample Menu Run  Window Help

ler-io [e]la- |

=
T5.Navigator #2 . Package E...

Notice in Figure 3, the default Hello World template adds a Sample Menu and
underneath it a Sample Action. It also adds a button to the toolbar with the Eclipse
icon on it like the Sample Action has. When the Sample Action or toolbar button is
clicked, the modal dialog in Figure 4 is displayed.

Figure 4. Hello World message dialog
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Helloworld Plug-in ' il

j}) Hello, Eclipse world

oK

The dialog shown in Figure 4 is not very interesting, so we will modify the behavior
to make it useful. We will change the behavior to locate the currently active editor,
get its absolute file name, and copy it to the operating system clipboard.

Create Plug-in Project and run Hello World template

To create the Plug-in Project and the initial plug-in from the Hello World template,
complete the following:

1. Select File > New Project > Plug-in Development > Plug-in Project to
start the Plug-in Project wizard.

2. Onthe Plug-in Project page, enter a project name of
comibmtutorial.tenpl at es. By convention, plug-in project names
have a similar format to a Java package name. This is helpful because
when they are installed, they are mixed together with other plug-ins. This
fully qualified name makes them easier to identify.

3. Click Next. The defaults for the Project Contents, Project Settings and
Alternate Format are fine.

4.  On the Plug-in Content page (see Figure 5), click Next. The defaults are
fine unless you want to provide a different Plug-in Name, Provider, or
Class Name.

Figure 5. Plug-in Content page
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£- New Plug-in Project i |

Plug-in Content

Enter the data required to generate the plug-n. @'3

—Plug-n Properties

Plug-n ID: | com.ibm. tutorial. templates

Flug-in Version: I 1.0.0

Plug-in Mame: |Tem|:ulates Plug-in

Plug-in Provider: I IEM

Runtime Library: I templates.jar

—Plug-in Class
¥ Generate the Java dass that controlz the plug-n's life cyde {recommended)

Class Mame: I com.ibm. tutorial templates. TemplatesFlugin
¥ This plug-n will make contributions to the LI

[ Intended for use with older Edipse platforms (prior to 3.0}

< Back Finish Cancel

5. Onthe Templates page, check Create a plug-in using one of the
following templates and select Hello World from the Available
Templates.

6. Click Next.

7.  Onthe Sample Action Set page, enter an Action Class Name of
CopyFi | enanmeActi on.

8. Click Finish to complete the wizard. The rest of the defaults are fine.

Plug-in project structure overview

Upon completing the Plug-in Project wizard and Hello World template, you will have
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a new Eclipse plug-in project. This project contains two classes and the plugin.xml
file. It also contains an icon and build.properties file. See Figure 6 to review the
contents of the newly created com i bm tut ori al . t enpl at es plug-in project.

Figure 6. Results of the Plug-in Project and Hello World template
et

Plug-ns Tom

L]

iy
E -

EITE..-“I com.ibm. tutorial. templates
L O src
. B3 com.ibm. tutorial templates
|I| TemplatesPlugin.java
EIEE com.ibm. tutorial, templates. actions
: |I| CopyFilenameAction.java
E-,,, Plug-in Dependendies
E.,,, JRE System Library [j2rel.4.2_06]
= icons

...... sy build.properties

Lk plugin. sl

Plug-in class

As mentioned, each Eclipse plug-in must contain a class that extends

org. eclipse. ui.plugin. Abstract U Pl ugi n (see Figure 7). Therefore, the
Plug-in Project wizard generates this class based on the Plug-in Class Name. For
this project, that class is Tenpl at esPl ugi n.

Figure 7. TemplatesPlugin inheritance hierarchy
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Figure 7 shows the hierarchy and significance of the generated Pl ugi n class to
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your plug-in. Because of this class' inherited relationship with

org. eclipse. ui.plugin. Abstract U Pl ugi n and

org. eclipse.core.runtime. Pl ugi n, it provides access to the Eclipse log,
plug-in preferences, and the Workbench, as well as whether the plug-in is in debug
mode or not. Also, since it implements the

or g. osgi . framewor k. Bundl eAct i vat or interface, it has the plug-in's life-cycle
methods of start and stop. Later, we will see where this class is configured in the

pl ugi n. xm so Eclipse can instantiate it.

package comibmtutorial.tenplates;

i mport org.eclipse.ui.plugin.*;
i mport org.osgi.framework. Bundl eCont ext ;
i mport java.util.*;
/**
* The main plugin class to be used in the desktop.
*/
public class Tenpl at esPl ugi n extends AbstractU Pl ugin {
/I The shared instance.
private static Tenpl at esPl ugi n pl ugi n;
/| Resour ce bundl e.
private ResourceBundl e resourceBundl e;

/**

* The constructor.

*/

publ i c Tenpl at esPl ugi n() {
super () ;
plugin = this;
try {

resour ceBundl e = Resour ceBundl e. get Bundl e(
"comibmtutorial.tenpl ates. Tenpl at esPl ugi nResour ces") ;
} catch (M ssingResourceException x) {
resourceBundl e = nul | ;

}
}
/**

* This method is called upon plug-in activation
*/
public void start(Bundl eContext context) throws Exception

super . start (context);

/**

* This method is called when the plug-in is stopped

*/

public void stop(Bundl eContext context) throws Exception

super. st op(cont ext);

/**
* Returns the shared instance.
*/
public static Tenpl atesPlugin getDefault() {
return plugin;

/**

* Returns the string fromthe plugin's resource bundl e,
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* or 'key' if not found.
*
/
public static String getResourceString(String key) {
Resour ceBundl e bundl e =
Tenpl at esPl ugi n. get Def aul t () . get Resour ceBundl e() ;

try {

return (bundle !'= null) ? bundle.getString(key): key;

} catch (M ssingResourceException e) {
return key;

}

}

/-k*

* Returns the plugin's resource bundl e,

*/

publ i ¢ ResourceBundl e get ResourceBundl e() {
return resourceBundl e;

developerWorks®

Notice the Tenpl at esPI ugi n class follows the singleton pattern. When accessing
this class, use the get Def aul t method. Eclipse will instantiate this class on your
behalf, so you are guaranteed this will return a valid instance. Also notice this class

provides access to a plug-in-specific resource bundle where you can store

internationalized labels.

Pop-up action

In addition to the Tenpl at esPl ugi n. j ava, the Hello Wizard template generated a
CopyFi | enanmeAct i on class. This class is the action that will be fired when the
menu item or button is chosen.

package comibmtutorial.tenplates. actions;

i mport org.eclipse.jface.action.|Action;

i mport org.eclipse.jface.viewers. | Sel ecti on;

i mport org.eclipse.ui.lWrkbenchW ndow,

i mport org.eclipse.ui.lWrkbenchW ndowAct i onDel egat e;
i mport org.eclipse.jface. di al ogs. MessageDi al og;

/

* Ok 3k X X

*
*

public class CopyFil enaneAction inplements | WrkbenchW ndowAct i onDel egat e {

*

Qur sanpl e action inplenents workbench action del egate.

The action proxy will be created by the workbench and

shown in the U . Wen the user tries to use the action,

this delegate will be created and execution will be
del egated to it.
@ee | Wr kbenchW ndowAct i onDel egat e

/

private | WrkbenchW ndow w ndow;,
/**
* The constructor.
=
publ i ¢ CopyFi |l enaneAction() {}

/**

* The action has been activated. The argunment of the
* method represents the 'real' action sitting
* in the workbench U .
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* @ee | WrkbenchW ndowAct i onDel egat e#r un
*/

public void run(lAction action) {
MessageDi al og. openl nf or mat i on(
wi ndow. get Shel | (),
"Tenpl ates Plug-in",
"Hell o, Eclipse world");
}
/**
* Sel ection in the workbench has been changed. W
* can change the state of the 'real' action here
* if we want, but this can only happen after
* the del egate has been creat ed.
*/ @ee | Wr kbenchW ndowAct i onDel egat e#sel ecti onChanged
*
public void sel ecti onChanged(
I Action action,
| Sel ection selection) {}

/**
* W can use this nethod to di spose of any system
* resources we previously allocated.
* @ee | WrkbenchW ndowAct i onDel egat e#di spose
*/
public void dispose() {}
/**

* W will cache wi ndow object in order to
* pbe able to provide parent shell for the
* message di al og.
* @ee | WrkbenchW ndowAct i onDel egat e#i ni t
*
/
public void init(lWrkbenchW ndow wi ndow) {
this.w ndow = wi ndow,

This code shows the default behavior of the r un method that displays the Hello
World message dialog. The r un method is the method we will change to implement
the new desired behavior of copying the absolute file name of the active editor to the
clipboard.

Plug-in Manifest file

The Plug-in Project wizard also generates a plugin.xml file shown in the code below.
This file is for all intents and purposes the plug-in deployment descriptor or manifest
file. It is read by Eclipse at startup and used to declaratively configure different
aspects of the plug-in, including descriptive information like its ID, name, version,
and provider. It also includes its classpath through the run time and requires
elements. Lastly, it identifies which points it wants to extend.

<?xm version="1.0" encodi ng="UTF- 8" ?>

<?ecl i pse version="3.0"?>

<pl ugi n
id="comibmtutorial.tenplates"
nane="Tenpl ates Pl ug-in"
version="1.0.0"
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© Copyright IBM Corporation 2005. All rights reserved. Page 16 of 74


http://www.ibm.com/developerworks/ibm/trademarks/
http://www.ibm.com/legal/copytrade.shtml

ibm.com/developerWorks developerWorks®

provi der - name="1 BM'
class="comibmtutorial.tenpl ates. Tenpl at esPl ugi n" >

<runti me>
<library nane="tenpl ates.jar">
<export name="*"/>
</library>
</runti me>

<requi res>

<inport plugin="org.eclipse.ui"/>

<inport plugin="org.eclipse.core.runtine"/>
</ requires>

<ext ensi on
poi nt ="org. ecl i pse. ui . acti onSet s" >
<act i onSet
| abel =" Sanpl e Action Set"
Vi si bl e="true"
id="comibmtutorial.tenplates. actionSet">
<menu
| abel =" Sanpl e &Wenu"
i d="sanpl eMenu" >
<separ at or
nanme="sanpl eG oup" >
</ separ at or >
</ menu>
<action
| abel =" &Sanpl e Acti on"
i con="i cons/sanple.gif"
class="comibmtutorial.tenplates.actions. CopyFi | enaneActi on"
tool ti p="Hell o, Eclipse world"
nmenubar Pat h="sanpl eMenu/ sanpl eG oup”
t ool bar Pat h="sanpl eG oup"
id="comibmtutorial.tenplates. actions. CopyFi | enanmeActi on">
</ action>
</ acti onSet >
</ ext ensi on>

</ pl ugi n>

There are several interesting items in this code. First, notice
comibmtutorial.tenplates. Tenpl at esPl ugi n is declared in the class
attribute of the pl ugi n element. This is how Eclipse knows to instantiate and call
the life-cycle methods of the Tenpl at ePl ugi n class. Next, notice the ext ensi on
element includes an act i onSet element. An acti onSet adds menus, menu
items, and toolbar items to the Workbench menus and toolbar. The act i onSet
includes a menu and action. The menu causes the Sample Menu to appear on the
main menu. It requires one or more separators to group actions. The action contains
declarative information about an Act i on class. This includes the label, icon, and
tool tip that should be used when displaying the action as a menu item or toolbar
button.

This is all configured declaratively so Eclipse can lazy-load the actual class that
implements the behavior based on the class attribute. Lazy-loading enables Eclipse
to start faster and use less memory. The lazy-loading pattern is common in Eclipse
plug-ins. For a menu to appear it must contain a menubar Pat h attribute that
contains the menu/group in which it belongs. For a toolbar button to appear, it must
contain a t ool bar Pat h attribute with a group name.

Building Eclipse plug-ins using templates Trademarks
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Modifying extensions

To make this plug-in copy the file name of the active editor, we are first going to
change the label and tool tip of the Sample Action to something more appropriate for
the copy file name behavior. We will then want to modify the behavior of the action
to copy the active editor's file name to the clipboard. To conclude, we will want to
add required plug-ins so classes can be found on the classpath.

To modify the Sample Action's label and tool tip, complete the following:

1. Open the plugin.xml file by double-clicking on it
2. Select the Extensions tab

3. Expandthe org. ecli pse. ui.actionSets in the All Extensions tree
until you see the Sample Action

4. Select the Sample Action; the Sample Action's properties will appear to
the right in the Extension Element Details area

5. Change the label to Copy Filename
6. Change the tool tip to Copy Active Editor's Filename to Clipboard

7.  Save plugin.xml by pressing Ctrl+S

Modifying action behavior

To modify the behavior of the CopyFi | enaneAct i on, replace the run method with
the code shown here:

public void run(lAction action) {
/1 get the active editor
i f (Wi ndow. get Acti vePage().getActiveEditor() != null)
{

IEditorPart editor =

wi ndow. get Acti vePage() . get Acti veEditor();
/] get the input editor that has reference to a file
i{f(edi tor.getEditorlnput() instanceof |FileEditorlnput)

IFileEditorlnput fileEditorlnput =
(I'FileEditorlnput) editor.getEditorlnput();

IFile file = fileEditorlnput.getFile();

/1 use location so the path is relative

/1l to the file system and not Eclipse workspace

| Path osPath = file.getlLocation();

Cli pboardUtil.copyTo(
osPat h. toFi |l e(). get Absol utePat h());

Building Eclipse plug-ins using templates Trademarks
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The behavior of displaying the message dialog has been changed to copying the
absolute file name of the active editor to the clipboard. This happens by first getting
the active editor. To get the active editor, we must use the

org. eclipse. ui .| Wr kbenchW ndowinstance passed into the i ni t method
and stored in the private window field. Using the window reference, we can call

get Act i vePage and get Act i veEdi t or to return an instance of
org.eclipse.ui.lEditorPart.|EditorPart isthe window that contains all
the editors. Once we have | Edi t or Par t , we can make sure it is an instance of

| Fi | eEdit or | nput and typecast it as such. We need to use | Fi | eEdi t or | nput
because it contains a get Fi | e method that returns an
org.eclipse.core.resources.|File.lFileisrelative to the current
workspace, so in order to get the file name relative to the operating system, we must
use | Fi | e's get Locat i on. Once we have the location, we can use it as a
java.io. Fil e withthet oFi | e method and call its get Absol ut ePat h. The
absolute path is then passed to a copy To method on a utility class called

Cl i pboardUti |, as shown below:

package comibmtutorial.util;

i mport org.eclipse.swt.dnd. dipboard;

i mport org.eclipse.swt.dnd. Text Tr ansf er;
i mport org.eclipse.swt.dnd. Transfer;

i mport org.eclipse.swt.w dgets. Di spl ay;

/**

* Utility nethods for working with the di pboard.
* @ut hor juddcl
*/

public class dipboardutil {

/**

* Copies Text to the clipboard.

* @aram t ext

*
/

public static void copyTo(String text) {
Clipboard clipboard =

new C i pboard(Di spl ay.getCurrent());

Text Transfer textTransfer = Text Transfer.getlnstance();
Transfer[] transfers = new Transfer[] { textTransfer };
Qoj ect[] data = new Object[] { text };
cli pboard. set Contents(data, transfers);

This code is a simple utility class used to abstract the complexities of copying a
String to the clipboard away from other code, such as the CopyFi | enaneActi on.

Modifying dependencies
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If you are following along and typing this example in your editor, you may have
noticed that some of the classes are not found. Even if you try to add the imports,
you still get a "class not resolved" error. This is because the classes are not included
in the classpath. In a regular Java project, you would use the Java Build Path to
include the JARSs containing the appropriate classes to the project's libraries. This is
not the case, however, for a plug-in project. Instead, you must add dependencies on
other plug-ins using the Dependencies tab of the Plug-in Manifest Editor.

Complete the following steps to add dependencies on the
org. eclipse.core.resources andorg. eclipse. ui.ide plug-ins:
1. Open the Plug-in Manifest Editor by double-clicking the plugin.xml file in
the Package Explorer
2. Select the Dependencies tab at the bottom of the editor window

3. Click Add in the Required Plug-ins area

4. Multi-select the or g. ecl i pse. core. resources and
org. eclipse. ui.ide plug-ins

5. Click OK

6. Save plugin.xml by pressing Ctrl+S

Run and debug

Now that the behavior has been modified and all the required plug-ins have been
configured, we are ready to run and/or debug the plug-in. This process is really no
different from running or debugging a regular Java application in Eclipse. You can
use the Run and Debug buttons on the toolbar, launch a run-time workbench, or
Launch a run-time workbench in Debug mode.

Under the covers, Eclipse creates a new launcher based on the Run-time
Workbench launch configuration. This launcher starts another instance of Eclipse
with your plug-in installed.

NOTE: Learning to use the debugger is outside the scope of this article. If you are
new to the Eclipse debugger, see the article listed in Resources.

To test the plug-in:

1. Click Run on the toolbar
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2. When the second instance of Eclipse starts, create a new project, and
add some classes to it

3.  Open one of the classes in the editor
4. Click Copy Active Editor's Filename to Clipboard on the toolbar

5. Inthe editor, paste the contents of the Clipboard on a blank line; you
should see the fully qualified name of the file

6. Close the second instance of Eclipse

Creating a feature

A feature is a collection of plug-ins. You may be asking yourself: "if we only have
one plug-in, why create a feature?" Well, features can make installation easier and
are required by an Update Site, which we will create in the next section. Features
also provide a good place for including a description, URL, copyright, and license
agreement for your plug-in.

To make a feature for this project:
1. Select File > New Project > Plug-in Development > Feature Project to
start the Feature Project wizard

2. On the Feature Name page, enter a project name of
comibmtutorial

3. Click Next
4. On the Feature Properties, keep the defaults by clicking Next

5. On the Referenced Plug-ins and Fragments page, check the
comibmtutorial.tenplates plug-in

6. Click Finish

Now that you have a feature for your plug-in, you can export your feature using the
Feature Manifest Editor's Overview. This will enable you to create a package for
your friends and family. The export options are to export as a single zip file, a
directory structure, or a JAR for an update site.

Creating an Update Site
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Distributing an exported feature as a zip file or directory might work for a small
amount of people, but for large organizations or to share with the Eclipse community
at large, you will want to create an Update Site. An Update Site is basically a
site.xml file and the packaged features and plug-ins on a Web server. The site.xml
file tells Eclipse where to locate the feature and plug-in JARS.

For others to install your plug-in, they can use the Find and Install option under the
Help > Software Updates menu.

To create an Update Site:
1. Select File > New Project > Plug-in Development > Update Site
Project to start the Update Site Project wizard

2.  Onthe Update Site Project page, enter a project name of
comibmtutorial.site

Check the "Generate a Web page listing all available features"

Click Finished

a &~ W

In the Site Manifest Editor's Features to Build area, click Add

6. Check the com i bm tut ori al feature in the Available Features list and
click Finish

7. Dragthecomibmtutorial fromthe Features to Build list to the
Features to Publish list

8. Click Build All on the Features to Build list to build and package all the
features in the list

You have now built an Update Site. To deploy it, copy the contents of your project to
a Web server, such as the Apache Web Server or Apache Tomcat.

Now that we understand how to write, test, package, and deploy plug-ins, we will
explore the remaining plug-in templates. Through the remainder of this tutorial, we
will add the existing plug-in to our current project.

Section 4. Popup Menu template
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Default Popup Menu template behavior

In this section, we will use the Popup Menu template as a starting point and modify
the behavior to copy a file object's absolute file name to the operating system's
clipboard.

The default behavior of the Popup Menu template plug-in is to add a New Submenu
> New Action menu to the plugin.xml files context menu (see Figure 8).

Figure 8. Popup Menu template menu
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When New Action is selected, the dialog shown in Figure 9 is displayed.

Figure 9. Popup Menu message dialog
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£- Popup Plug-in . |

i) Mew Action was executed.

The dialog shown in Figure 9 is not very interesting, so we will modify the behavior
to make it useful. We will change the behavior to copy the file's absolute file name to
the operating system clipboard.

Run Popup Menu template

When we ran the Hello World template, we ran it as part of creating a new Plug-in
Project. However, if we already have an existing project, we can still use the
templates. For this template and the rest, we will use templates to extend our

existingcom i bm tutori al . tenpl at es project by running the template wizards
from the Plug-in Manifest Editor.

To run the Popup Menu template:

1. Open the Plug-in Manifest Editor by double-clicking the plugin.xml file
2. Select the Extensions tab at the bottom of the editor

3.  On the Extensions tab, click Add

4. Onthe New Extension dialog, select Extension Wizards

5

Select Extension Templates to display the seven templates covered in
this tutorial, as well as the Help Content and Preference Page templates

6. Select the Popup Menu template and click Next

7.  Onthe Sample Popup Menu page, set the Name Filter to *, the Action
Label to Copy Filename, and the Action Class to CopyFi | enaneAct i on

8. Click Finish

Review Popup Menu template results
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After running the Popup Menu template, a new CopyFi | enaneActi on. j avais
added to the project, and a new extension point is added to plugin.xml.

The code for the CopyFi | enaneAct i on Popup Menu:

package comibmtutorial.tenplates. popup. actions;

i mport org.eclipse.jface.action.|Action;

i mport org.eclipse.]face. di al ogs. MessageDi al og;
i mport org.eclipse.jface.viewers.|Sel ection;

i mport org.eclipse.swt.w dgets. Shel | ;

i mport org.eclipse.ui.lObjectActi onDel egat e;

i mport org.eclipse.ui.lWrkbenchPart;

public class CopyFil enameActi on
i mpl enents | Cbj ect Acti onDel egate {

/**
* Constructor for Actionl.
*/
publ i ¢ CopyFi | enaneAction() {
super () ;
/**

* @ee | Obj ect Acti onDel egat e#set Acti vePart (
kJ | Action, |WrkbenchPart)
*/

public void setActivePart(lAction action,
| Wor kbenchPart targetPart) {}
/**
* @ee | ActionDel egat e#run( |l Acti on)
*/
public void run(lAction action) {
Shel | shell = new Shell ();
MessageDi al og. openl nf or mat i on(
shel I,
"Tenpl ates Plug-in",
"Copy Fil enane was executed.");

}

/**
* @ee | ActionDel egat e#sel ecti onChanged(
2 | Action, |Selection)
*/

public void sel ecti onChanged( | Acti on acti on,
| Sel ection selection) {}

The code is an action that implements the

org. eclipse.ui.lQbjectActi onDel egat e interface. Its behavior is similar to
that of the default Hello World template. Next, we will modify this behavior to copy
the absolute file name to the operating system clipboard.

The code for the Popup Menu extension point added to plugin.xml:

<ext ensi on poi nt="org. ecl i pse. ui . popupMenus" >
<obj ect Cont ri buti on
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obj ect Cl ass="org. ecl i pse. core.resources. | File"
nanmeFilter="*"
id="comibmtutorial.tenplates.contributionl">
<nenu
| abel =" New Subnenu”
pat h="addi ti ons"
Id="comibmtutorial.tenplates. nenul">
<separ at or nane="groupl"/>
</ menu>
<action
enabl esFor="1"
| abel =" Copy Fi |l enane"
cl ass=
"comibmtutorial.tenpl ates. popup. acti ons. CopyFi | enaneActi on"
nmenubar Pat h=
"comibmtutorial.tenplates. menul/ groupl”
id="comibmtutorial.tenplates.newAction"/>
</ obj ect Contri buti on>
</ ext ensi on>

With this, CopyFi | enaneAct i on is added to any object of any view, including the
Package Explorer and Resource Navigator that is an instance of the

org. eclipse. core.resources. | Fil e interface. Just like the Hello World
Template, it creates a menu and group. The action itself is then associated with the
menu and group using the nenubar Pat h.

Modify Popup Menu behavior

Make the following highlighted changes to modify the behavior of the Popup Menu to
copy the absolute file name:

package comibmtutorial.tenplates. popup. actions;

i mport org.eclipse.core.resources.|File;

i mport org.eclipse.core.runtine. | Path;

i mport org.eclipse.jface.action.|Action

i mport org.eclipse.jface.viewers.| Sel ection

i mport org.eclipse.jface.viewers.|StructuredSel ection
i mport org.eclipse.ui.lCbjectActionDel egat e;

i mport org.eclipse.ui.lWrkbenchPart;

import comibmtutorial.util.CipboardUtil;
/**

* Popup nenu to copy the absolute filenane to the
* cl 1 pboard
*/
public class CopyFil enaneAction i npl ements
| Obj ect Acti onDel egat e
{

private | Sel ection sel ection;

/**

* @ee | bj ect ActionDel egat e#set Acti vePart (
@ I Action, |WrkbenchPart)
*/

public void setActivePart (
I Action action, |WrkbenchPart targetPart) {}
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/**

* @ee | ActionDel egat e#run(l Acti on)
*/

public void run(lAction action) {
IFile file = getFile();
I Path osPath = file.getLocation();
Cli pboardUtil.copyTo(
) osPat h.toFil e(). get Absol utePath());

/**
* @ee | ActionDel egat e#sel ecti onChanged(
* I Action, |Selection)
*/

public void sel ecti onChanged(
I Action action, |Selection selection)

this.selection = sel ection;

private IFile getFile() {
return (IFile)
((I'StructuredSel ection)sel ection)
.getFirstEl ement ();
}
}

We have now added the private field of selection. This stores a collection of the
currently selected items in the tree. It is set in the sel ect i onChanged method
called anytime a new item in the tree is selected.

A get Fi | e method was added to simplify typecasting the first item in the selection
to the desired | Fi | e.

The r un method used above is similar to the implementation of the Hello World
template example shown earlier. The only difference is that the file reference is
obtained from the get Fi | e method in this instance. Like before, it uses

get Locat i on to get the file name relative to the operating system, rather than the
workspace. Then we get a reference to j ava. i 0. Fi | e and pass its absolute file
name to the C i pboardUti | class.

ibm.com/developerWorks

Section 5. Property Page template

Default Property Page template behavior

The default Property Page template creates the properties page shown in Figure 10.
This page appears when you right-click on a file and choose Properties.
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Figure 10. Default Property Page
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As you can see, the Property Page displays the path, as well as the owner. What
you cannot see, however, is that the owner can be modified and will be saved if
Apply or OK is clicked. The Restore Defaults will also set the value of Owner back
to John Doe if it has been changed. So, this template provides a good example of
how to persist properties on an object.

Run Property Page template

To create a default Properties Page from the template in the existing project:

a M

6.
7.

Open the Plug-in Manifest Editor by double-clicking the plugin.xml file
Select the Extensions tab at the bottom of the editor

On the Extensions tab, click Add

On the New Extension dialog, select Extension Wizards

Select Extension Templates

Select the Property Page template and click Next

Click Finish to accept the defaults shown in Figure 11

Figure 11. Sample Property Page defaults
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x
Ssample Property Page
This template adds a property page to a resource and will appear in the Properties -1')__
Dialog for that resource, 1
Java Package Mame: I corm,ibm. tutorial. templates. properties
Property Page Class: | SamplePropertyPage
Property Page Mame: | Sample Page
Target Class: I org.edipse. core, resources, IFie
Mame Filter: I it
< Back | NExkz | Finish Cancel

Review Property Page template results

After running the Property Page Template, a new Sanpl ePr opert yPage. j ava is
added to the project, and a new extension point is added to plugin.xml.

Adding Sanpl ePr opert yPage. | ava:

Trademarks
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package comibmtutorial.tenplates. properties;

i mport org.eclipse.core.resources. | Resource;

i mport org.eclipse.core.runtinme. CoreException;
i mport org.eclipse.core.runtine. QalifiedNanme;
i mport org.eclipse.swt.SWT;

i mport org.eclipse.swt.|ayout.GidDat a;

i mport org.eclipse.swt.layout.GidLayout;

i mport org.eclipse.sw.w dgets. Conposite;

i mport org.eclipse.swt.w dgets. Control;

i mport org.eclipse. swt.w dgets. Label;

i mport org.eclipse.swt.w dgets. Text;

i mport org.eclipse.ui.dial ogs. PropertyPage;

public class Sanpl ePropertyPage extends PropertyPage {
private static
private static
ic

ic

private stat
private stat

final String PATH TITLE = "Path:";

final String OMER Tl TLE = "&Owner:";
final String OMER PROPERTY = "OMER';
final String DEFAULT_OMER = "John Doe";

private static final int TEXT_FI ELD W DTH = 50;

private Text owner Text;

/**
* Constructor for Sanpl ePropertyPage.
*
/
publ i ¢ Sanpl ePropertyPage() {
super () ;

private voi d addFirst Secti on(Conposite parent) {
Conposi te conposite = createDef aul t Conposite(parent);

//Label for path field
Label pathLabel = new Label (conposite, SWI. NONE);
pat hLabel . set Text (PATH_TI TLE) ;

/] Path text field
Text pat hVal ueText =

new Text (conposite, SW. WRAP | SWI. READ_ONLY) ;
pat hVal ueText . set Text (

((I Resource) getElenent()).getFullPath().toString());

private void addSeparat or (Conposite parent) {
Label separator =

new Label (parent, SW.SEPARATOR | SW. HORI ZONTAL) ;

GidData gridData = new GidData();

gri dDat a. hori zontal Al i gnment = GridData. FI LL;
gri dDat a. gr abExcessHori zont al Space = true;
separ at or. set Layout Dat a(gri dDat a) ;

}

private void addSecondSecti on( Conposite parent) {
Conposite conposite = createDefaul t Conposite(parent);

/] Label for owner field
Label ownerLabel = new Label (conposite, SWI. NONE);
owner Label . set Text (OANER_TI TLE) ;

/] Omer text field
owner Text =
new Text (conposite, SWI. SINGLE | SW. BORDER) ;
GidData gd = new GidData();
gd. wi dt hHi nt =
convert W dt hl nChar sToPi xel s( TEXT_FI ELD W DTH) ;
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owner Text . set Layout Dat a(gd) ;

/1 Popul ate owner text field
try {
String owner =
((I Resource) getEl enment()).getPersistentProperty(
new QualifiedNanme("", OMER_PROPERTY)) ;
owner Text . set Text ((owner != null) ?
owner : DEFAULT_OWNER);
} catch (CoreException e) {
owner Text . set Text ( DEFAULT_OWNER) ;

}
}

/

* *

* @ee PreferencePage#creat eCont ent s( Conposite)
*/

protected Control createContents(Conposite parent) {

}

Conposite conposite = new Conposite(parent, SWI. NONE);
GidLayout |ayout = new GidLayout();

conposi te. set Layout (| ayout) ;

GidData data = new Gidbata(GidData. FI LL);

dat a. gr abExcessHori zont al Space = true;

conposi te. set Layout Dat a(dat a) ;

addFi r st Secti on(conposite);
addSepar at or (conposi te);
addSecondSect i on(conposite);
return conposite;

private Conposite createDefaul t Conposite(

{

}

Conposi te parent)

Conposite conposite = new Conposite(parent, SW. NULL);
GridLayout |ayout = new GidLayout();

| ayout . nunCol umms = 2;

conposi t e. set Layout (| ayout) ;

GidData data = new GidData();
data.vertical Alignment = GidbData. FI LL;
dat a. hori zontal Al'i gnnent = GridData. FI LL;
conposi te. set Layout Dat a(dat a) ;

return conposite;

protected void perfornDefaul ts() {

}

/1 Popul ate the owner text field with the default val ue
owner Text . set Text ( DEFAULT_OWNER) ;

publ i ¢ bool ean perfornk() {

}

/1 sEore the value in the owner text field
try
((IResource) getElenment()).setPersistentProperty(
new Qual i fi edName("", OAMER_PROPERTY),
owner Text . get Text ());
} catch (CoreException e) {
return fal se;

return true;

First, notice the generated Sanpl ePr opert yPage class extends

Building Eclipse plug-ins using templates Trademarks
© Copyright IBM Corporation 2005. All rights reserved. Page 32 of 74


http://www.ibm.com/developerworks/ibm/trademarks/
http://www.ibm.com/legal/copytrade.shtml

ibm.com/developerWorks developerWorks®

org. eclipse. ui.dial ogs. PropertyPage. Actually, it has a long lineage since
Propert yPage extends or g. ecl i pse. j face. preference. Pref erencePage,
and that extends or g. ecl i pse. j face. di al ogs. D al ogPage. It is through this
lineage that Sanpl ePr oper t yPage gets the methods cr eat eCont ent s,

per f or nDef aul t s, and per f or nCk, which it overrides.

The cr eat eCont ent s method is called when the property page is displayed. It is

overridden to create the Composite for holding all the components displayed on the
page. Internally, it does some layout work, then delegates to the private methods of
addFi r st Secti on, addSecondSect i on, and addSepar at or to add the actual
components.

The per f or nDef aul t s method is executed when the Restore Defaults button is
clicked. It also overrides a super-class method. Its implementation populates the
Text box to the default of John Doe.

The per f or Ok method is executed when the OK or Apply button is clicked. It first
calls get El enrent implemented by a super class. The get El enent returns the file
object originally selected. Using the file as a resource, it calls

set Per si st ent Properti es. This saves the value of the owner Text box in the
workspace with a relationship to the file.

The extension point in the following code instructs Eclipse to add the
Sanpl ePr opert yPage to every file property that has a filer of *. *. This would
include all views, such as the Package Explorer and Resource Navigation.

<ext ensi on poi nt="org. ecl i pse. ui . propertyPages" >
<page
obj ect Cl ass="org. ecl i pse. core.resources. | File"
naneFi [ ter="*. *"
cl ass=
"comibmtutorial.tenplates. properties. Sanpl ePropertyPage"
nanme="Sanpl e Page"
i d=
"comibmtutorial.tenpl ates. properties. sanpl ePropertyPage"
/>
</ ext ensi on>

Section 6. View template

Default View template behavior

In this section, we will review the default View Template. By default, the View
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template creates a view, a dockable window inside Eclipse that contains a table and
becomes apart of the Resource Perspective (shown in Figure 12).

Figure 12. Sample Table viewer
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Optionally, the view can be generated to contain a tree, rather than a table (see
Figure 13).
Figure 13. Sample Tree view
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The View template wizard also provides a list of optional features that can be
enabled and disabled, including double-click support, pop-up menus, toolbar menus,
pull-down menus, sorting, and drill-down.
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This view is also added to the Show View list under the Sample Category. It can be
added to other Perspectives by selecting Window > Show View > Other > Sample
Category > Sample View.

Run View template behavior

To create a default Sample View from the template in the existing project:

1. Open the Plug-in Manifest Editor by double-clicking the plugin.xml file

2. Select the Extensions tab at the bottom of the editor

3.  On the Extensions tab, click Add
4. Onthe New Extension dialog, select Extension wizards
5. Select Extension Templates

6. Select the Sample View template and click Next

7. Select Next to accept the defaults shown in Figure 14
Figure 14. Main View setting defaults
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B

Main View Settings
Choose the way the new view will be added to the plug-in. -D

Java Package Mame: I com.ibrm, tutorial, templates. views

View Class Name: I SampleView

View MName: I Sample View

View Category Id: I com.ibm. tutorial. templates

‘fiew Category Mame: I Sample Category

Select the viewer type that should be hosted in the view:

¥ Table viewer (can also be used for lists)
" Tree viewer

v add the view to the resource perspective

< Back Mext = Finish Cancel

8. Click Finish to accept the defaults shown in Figure 15
Figure 15. Main View setting defaults
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X

I3

= View N

View Features

Choose the features that the new view should have. -:_j
|Chu:n:se the features that

¥ add double-click support

W add actions to the pop-up menu

W add actions to the view's tool bar

W add actions to the view's pul-down menu
W add support for sorting

¥ add drill-devwn capabilicy

< Back | [ | Einish Cancel

Review View template behavior results

After running the View template, a new Sanpl eVi ew. | ava is added to the project,
and two new extension points are added to pl ugi n. xm .

The code for the Sanpl eVi ew. j ava, with some details removed for brevity:

package comibmtutorial.tenplates.views;

i mport org.eclipse.sw.w dgets. Conposite;
i mport org.eclipse.ui.part.?*;
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i mport org.eclipse.jface.viewers.*;

i mport org.eclipse.sw.graphics.|nmge;

i mport org.eclipse.jface.action.*;

i mport org.eclipse.jface. di al ogs. MessageDi al og;
i mport org.eclipse.ui.*;

i mport org.eclipse.swt.w dgets. Menu;

i mport org.eclipse.swt.SWT;

public class Sanpl eVi ew extends ViewPart {

cl ass Vi ewCont ent Provi der i npl enments
| St ruct ur edCont ent Pr ovi der

public void i nput Changed(
Vi ewer v, Cbject oldlnput, Ooject newl nput) {}

public void dispose() {}

public Object[] getEl ements(Object parent) ({
return new String[] { "One", "Two", "Three" };

}
}
cl ass Vi ewlLabel Provi der extends Label Provi der
i mpl ement s | Tabl eLabel Provi der

public String get Col umText (CObj ect obj, int index) {
return get Text (obj);

public 1 mage get Col uml mage( Gbj ect obj, int index) {
return getlmage(obj);

public I mage getl mage(Obj ect obj) {
return Pl atformJ .get Workbench().
get Shar edl nages() . get | mage(
| Shar edl mages. | MG_OBJ_ELEMENT) ;

}
}
cl ass NaneSorter extends ViewerSorter {}
/**
: The constructor.
pué)l i c Sanpl eView) {}
/**

* This is a callback that will allow us

*/to create the viewer and initialize it.

*

public void createPart Control (Conposite parent) {
vi ewer = new Tabl eVi ewer (
parent, SWI. MULTI | SWI. H SCROLL | SWI. V_SCROLL);

vi ewer . set Cont ent Provi der (new Vi ewCont ent Provi der ());
vi ewer . set Label Provi der (new Vi ewlLabel Provi der());
vi ewer . set Sorter (new NaneSorter());
vi ewer.setlnput(getViewSite());
makeAct i ons();
hookCont ext Menu() ;
hookDoubl el i ckActi on();
contri but eToActi onBars();

}

private voi d hookCont ext Menu() {
/] details renoved

Building Eclipse plug-ins using templates Trademarks
© Copyright IBM Corporation 2005. All rights reserved. Page 38 of 74


http://www.ibm.com/developerworks/ibm/trademarks/
http://www.ibm.com/legal/copytrade.shtml

ibm.com/developerWorks developerWorks®

}

private void contributeToActionBars() {
/] details renoved

}

private void makeActions() {
actionl = new Action() {
public void run() {
) showvessage("Action 1 executed");
3

actionl. set Text ("Action 1");
actionl. set Tool Ti pText ("Action 1 tooltip");
actionl. set| nmageDescri pt or (
Pl at f or mJl . get Wr kbench() . get Shar edl nages() .
get | mageDescri pt or (
| Shar edl mages. | MG_OBJS_I NFO_TSK) ) ;

[/l details renmoved

/**
* Passing the focus request to the viewer's control.
*/
public void setFocus()
vi ewer . get Control (). set Focus();

}

In this code, some details have been removed for brevity, but most of the major
concepts still remain. First, notice Sanpl eVi ew extends

org. eclipse.ui.part.ViewPart. This is the super class of all views. Next,
notice this class has three inner classes: Vi ewCont ent Pr ovi der,

Vi ewLabel Provi der, and NanmeSor t er . The combination of

Vi ewCont ent Provi der and Vi ewLabel Provi der is similar to the Table Model
concept in Swing. Vi ewCont ent Pr ovi der contains all the data. If you want your
table to contain data other than One, Two, and Three, you should change the
implementation of this class. The Vi ewlLabel Provi der determines how the data
from Vi ewCont ent Pr ovi der is displayed. It can include text and images. In this
case, it just uses the t oSt ri ng of the objects from the Vi ewCont ent Pr ovi der
and displays an image. The NaneSor t er extends Vi ewer Sort er, which
iImplements a case-insensitive text comparison to determine order. This is the
reason the order of the numbers are One, Three, and Two.

You will probably want to change the behavior of the generated actions that
correspond to the pop-up menu, toolbar, and pull-down menu actions. These actions
are created in the nakeAct i ons method. To change the actions' behavior, change
their respective r un method. Also feel free to change the text, tool tip, and other
characteristics of the action.

The code for the View and Perspective Extension extension points added to
plugin.xml:
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<ext ensi on point="org. eclipse. ui.views">
<cat egory
nane="Sanpl e Cat egory"
id="comibmtutorial.tenplates"/>
<vi ew
class="comibmtutorial.tenplates.vi ews. Sanpl eVi ew'
i con="i cons/sanple.gif"
category="comibmtutorial.tenplates"
nane="Sanpl e Vi ew'
id="comibmtutorial.tenplates.views. Sanpl eVi ew'/ >
</ ext ensi on>
<ext ensi on poi nt="org. ecli pse. ui . perspecti veExt ensi ons" >
<per spect | veExt ensi on
target| D="org. eclipse. ui.resourcePerspective">
<vi ew
rati o="0.5"
rel ati onshi p="right"
rel ati ve="org. eclipse. ui.vi ews. TaskLi st"
id="comibmtutorial.tenplates.views. Sanpl eVi ew'/ >
</ per spect i veExt ensi on>
</ ext ensi on>

The first extension point in the previous code adds a category called Sample
Category. Next, it adds the Sample View and adds the Sample View to the Sample
Category using the category attribute.

The second extension point in the previous code adds the Sample View to the
Resource Perspective. Specifically, it adds it directly to the right of the TaskList and
takes up 50 percent of the space, according to the ratio.

NOTE: To see a new view added to a perspective, you may have to reset the
perspective by choosing Window > Reset Perspective from the main menu.

Section 7. Perspective Extension template

Default Perspective Extension behavior
In this section, we will review the default Perspective Extension template.

By default, the Perspective Extension template modifies the configuration of the
Resource perspective by adding the JavaActionSet (see figures 16 and 17), Debug
Perspective shortcut, Type Hierarchy View shortcut, New Project Wizard menu, and
the Package Explorer View.

Figure 16 shows that the Package Explorer is added to the Resource perspective
behind the Resource Navigator. It also shows that the JavaActionSet adds the Open
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Type button to the toolbar.

Figure 16. Highlight of Package Explorer View and JavaActionSet
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By default, the Resource Perspective does not have the JavaAct i onSet enabled.
Figure 17 -- the Customize Perspective dialog available from Window > Customize
Perspective > Commands -- shows the Perspective Extension with the
JavaActionSet enabled, which has a label of Java Navigation. This means the menu
bar of the Resource Perspective will have an Open Type and Open Type in
Hierarchy menu items on the Navigate menu and the Generate Javadoc on the
Project menu. Figure 17 also shows that the Open Type is added to the toolbar,
which we saw in Figure 16.

Figure 17. JavaActionSet enabled in the Customize Perspective
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Debug Perspective

Figure 18 shows the Debug Perspective added to the Perspective shortcut list. The
Perspective shortcut list is under the Open a perspective button, as shown in Figure
18, and on the Window > Open Perspective menu.

Figure 18. Debug Perspective shortcut
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Figure 19 shows the Type Hierarchy added to the shortcut list on the Window >
Show View menu.

Figure 19. Type Hierarchy View shortcut
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Run Perspective Extension behavior

To create an extension to the Resource Perspective with the Perspective Extension
template in an existing project:
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1. Open the Plug-in Manifest Editor by double-clicking the plugin.xml file

2. Select the Extensions tab at the bottom of the editor

3.  On the Extensions tab, click Add
4. Onthe New Extension dialog, select Extension Wizards
5. Select Extension Templates

6. Select the Perspective Extensions template and click Next

7.  Click Next to accept the defaults shown in Figure 20
Figure 20. Perspective Extensions Target and Shortcuts page
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Perspective Extensions 1: Target and Shortcuts
Add an action set and shortcuts to the target perspective

e

org.edipse. jdt.ui, wizards. NewProjectCreationWizard |

8.  Click Finish to accept the defaults shown in Figure 21
Figure 21. Perspective Extensions View page
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£- Perspective Extensions |

Perspective Extensions 2: View
Add a view to the target perspective -i)

View ID: | org.edipse. jdt. ui.PackageExplorer

Relative View: I org. edipse. ui. views.ResourceMavigator
Relative Position:

&+ Stack

" Fast

" Left

" Right

f-' Top

" Bottom

< Back Mexk = | Finish Cancel

Review Perspective Extension behavior results

The Perspective Extension template is interesting because it does not generate any
code. Instead, it adds configurations to the plugin.xml file, as shown below:

<ext ensi on
poi nt ="org. ecl i pse. ui . per specti veExt ensi ons" >
<per spect i veExt ensi on
target| D="org. eclipse. ui.resourcePerspective">
<vi ew
rati o="0.5"
rel ati onshi p="right"
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rel ati ve="org. eclipse. ui.vi ews. TaskLi st"
id="comibmtutorial.tenplates.views. Sanpl eVi ew'/ >
</ per spect i veExt ensi on>
<per specti veExt ensi on
target| D="org. ecli pse. ui.resourcePerspective">
<newN%zardShortcut
] =
"org.eclipse.jdt.ui.w zards. NewProj ect Creati onWzard"/ >
<vi ewShortcut id="org.eclipse.jdt.ui.TypeH erarchy"/>
<per specti veShort cut
i d="org. ecl i pse. debug. ui . DebugPer specti ve"/ >
<actionSet id="org.eclipse.jdt.ui.JavaActionSet"/>
<vi ew
rel ati onshi p="st ack"
rel ati ve="org. ecl i pse. ui . vi ews. Resour ceNavi gat or"
i d="org. eclipse.jdt.ui.PackageExpl orer"/>
</ per spect i veExt ensi on>

The first per spect i veExt ensi on was added by the View template. The second
per spect i veExt ensi on was added by the Perspective Extension.

The Perspective Extension template configuration adds the New Project Creation
Wizard as a New Wizard shortcut. Then it adds the Type Hierarchy view to the View
shortcuts, followed by adding the Debug Perspective to the Perspective shortcut.
Next, the JavaAct i onSet is enabled with an Action Set. Last, the Package
Explorer view is stacked under the Resource Navigator view.

NOTE: You may have to reset the perspective by choosing Window > Reset
Perspective from the main menu to see changes to the perspective.

Section 8. Editor template

Default Editor template behavior

By default, the Editor template generates a fully functional XML Editor (see Figure
22) and associates it with the *. xm file type (see Figure 23).

Figure 22 shows an example of the XML Editor at work on a cust oner . xni file.
Notice the editor has syntax highlighting for processing instructions, comments,
elements, and attributes.

Figure 22. XML Editor generated by Editor template
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Figure 23 shows that the *. xnl file type is associated with the Sample XML Editor
in the Workbench properties found under the Windows > Preferences menu.

Figure 23. XML Editor file association
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Run Editor template behavior

To create the XML Editor with the Editor template in an existing project:

1. Open the Plug-in Manifest Editor by double-clicking the plugin.xml file

2. Select the Extensions tab at the bottom of the editor

o o & W
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On the New Extension dialog, select Extension Wizards

Trademarks
Page 49 of 74


http://www.ibm.com/developerworks/ibm/trademarks/
http://www.ibm.com/legal/copytrade.shtml

developerWorks® ibm.com/developerWorks

7.  Click Next to accept the defaults shown in Figure 24
Figure 24. Sample XML Editor defaults

£— New plug-in project with a sample XML editor x|
Sample XML Editor e

Choose the options that will be used to generate the XML editor, =-\D:

Java Package Mame: I Editor. editors

Editor Class Name: | XMLEditor

Editor Name: | Sample XML Editor

File Extension: I xml

Mdext = | Einish Cancel

Review Editor template behavior results

The Editor template is the most complex of the plug-in templates since it generates
the most code (12 Java files in all) and most working parts. Rather than explain each
line of code, we will use the UML diagram in Figure 25 to explain the classes. As
always, we will review the plugin.xml changes in the code below.

Figure 25. XML Editor UML
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The XMLEdi t or is the primary class, even though it does not do much except
associate itself with the Col or Manager , XM_Docunent Pr ovi der , and

XM_Conf i gur at i on, which are used for mapping and caching colors, acting as a
controller, and configuring the XML parsing, respectively. The rest of the classes --
XM_Doubl ed i ckSt r at egy, XM_Scanner , XM_TagScanner ,

XM_Whi t espaceDet ect or, XMLPartiti onScanner, and TagRul e -- are used to
support the XML parsing.

The lone interface, | XM_Col or Const ant s, contains a list of RGB color constant
mappings to XML types:

<ext ensi on point="org. eclipse.ui.editors">
<edi t or

class="comibmtutorial.tenplates.editors. XM_Edi tor"
i con="i cons/sanple.gif"
contributorC ass=

"org.eclipse.ui.texteditor.BasicText EditorActi onContri butor"
nanme="Sanpl e XM_ Editor"
id="comibmtutorial.tenplates.editors. XM_Editor"
ext ensi ons="xml "/ >

</ ext ensi on>
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This code shows the extension point that adds the XML Editor. The class attribute
uses the generated XMLEdi t or class. The icon is the default Eclipse icon. Figure
23 shows the icon being used in the file association. The icon is also used in the
Open With context menu on XML files. The cont ri but or Cl ass attribute tells
Eclipse to include basic editor menus. The name identifies the editor name. You can
see how the editor name is used in the file association preferences page in Figure
23. Last, the editor is associated with *. xm files with the extensions attribute.

Section 9. Multi-page Editor template

Default Multi-page Editor template behavior

By default, the Multi-page Editor template generates a trivial editor with three pages
and a wizard for generating files associated with the editor. The editor enables text
to be typed in a text editor on the first page (see Figure 26), previewed on the third in
a read-only format with each word on a separate line and ordered alphabetically
(see Figure 27), and the ability to control the font of the third page from the second
(see Figure 28).

The first page of the Multi-page Editor shown in Figure 26 is a simple text editor. You
can use it to type anything you want. The text can then be previewed on the third, or
Preview, page shown in Figure 27.

Figure 26. First page of the Multi-page Editor

Building Eclipse plug-ins using templates Trademarks
© Copyright IBM Corporation 2005. All rights reserved. Page 52 of 74


http://www.ibm.com/developerworks/ibm/trademarks/
http://www.ibm.com/legal/copytrade.shtml

ibm.com/developerWorks developerWorks®

This is the initial file contencs for *.mpe file ;l

Y | o

new_file.mpe | Properties | Praview |

Notice in Figure 27, the sentence from Figure 26 has been reordered so the
sentence is now in alphabetical order. In addition, each word is separated on its own
line.

Figure 27. Third page of the Multi-page Editor

contents
editor
file

file

for

in

initial

is )
mpe
multi

of

page

page
Preview i
A :
new_file.mpe | Properties |F're=.riew |

The second, or Properties, page shown in Figure 28 only has as a single property to
set -- the font of the third or Preview page.

Figure 28. Second page of the Multi-page Editor
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B

new_file.mpe |F'ru:nper1jEJ Preview |

Default Multi-page Editor template behavior, continued

This Multi-page Editor is associated with a file extension of *. npe, which stands for
Multi-page Editor. To create a new file of this type, the Multi-page Editor generates
the Multi-page Editor file wizard, shown in figures 29 and 30.

Figure 29 shows the new Multi-page Editor file wizard located in the Sample Wizards
category.

Figure 29. Multi-page Editor File wizard
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Enew x|

Select a wizard

Wizards:

..... @' Class

----- -ﬁ] Extension Point Schema
----- &% Interface

----- [J° Java Project

4}53 Plug-in Project

&= CVS

= Java

[-[= Plug-in Development
E-{z=- Sample Wizards
Multi-page Editor file
[E; Simple

= Back Mext = Eimish Cancel

Figure 30 shows that the Multi-page editor collects two pieces of information. First is
the Container, or Folder. The second is the name of the file. By default, the new file
will contain the sentence in Figure 26.

Figure 30. Multi-page Editor File wizard
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= x|
Multi-page Editor File

This wizard creates a new file with * mpe extension that can be opened by a
multi-page editar,

Container: |,|“Test Browse. .. |

Eile name: | new_file.mpe

exh = | Einish Cancel

Run Multi-page Editor template behavior

To add the Multi-page Editor and Multi-page Editor File wizard to an existing project:

1. Open the Plug-in Manifest Editor by double-clicking the plugin.xml file
2. Select the Extensions tab at the bottom of the editor

3. On the Extensions tab, click Add
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4. On the New Extension dialog, select Extension Wizards

5. Select Extension Templates

6. Select the Multi-page Editor template and click Next

7.  Click Finish to accept the defaults shown in Figure 31

Figure 31. Sample Multi-Page Editor

£= Multi- page Editor N

sample Multi-Page Editor

Choose the options that will be used to generate the multi-page editor.

developerWorks®

Java Package Mame:

I com.ibm. tutorial. templates. editors

Editor Class Name: | MultiPageEditor

Editor Contributor Class Mame: | MultiPageEditorContributor

Editor Mame: I Sample Multi-page Editor

File Extension: | mpe

< Back

hext =

Finish

Cancel

8. Click Add again

9. Onthe New Extension dialog, select Extension Wizards
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10. Select Extension Templates

11. Select the New File Wizard template and click Next

12. Click Finish to accept the defaults shown in Figure 32
Figure 32. New wizard options

Hew Wizard Options

The provided options contral the new wizard that will be created.

ibm.com/developerWorks

Java Package Mame: I com.ibm. tutorial. templates. wizards

Wizard Category Id: I com.ibrm. tutorial. templates

Wizard Category Mame: | Sample Wizards

Wizard Class Mame: I SampleMew\Wizard

Wizard Page Class Mame: I SampleMewWizardPage

Wizard Mame: I Multi-page Editor file
File Extension: I mpe
Initial File Name: I new_file.mpe

< Back | Mexk =

Finish

Cancel

Review Multi-page Editor template behavior results

The Multi-page Editor generates four Java files. Two are related to the editor and the

other two are responsible for the wizard. The two editor classes are the
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Mul ti PageEdi t or and the Mul ti PageEdi t or Cont ri but or, which are the
editor itself and the class responsible for managing global actions for the editor. The

two wizard classes are the Sanpl eNewW zar d and a page in that wizard,

Sanpl eNewW zar dPage.

The code for the Mul t i PageEdi t or class:

package comibmtutorial.tenplates. editors;

import java.io.StringWiter;

i nport java.text.Coll ator;

import java.util.Arraylist;
import java.util.Collections;
import java.util.StringTokeni zer;

i mport org.eclipse.
i mport org.eclipse.
i mport org.eclipse.
i mport org.eclipse.
i mport org.eclipse.
i mport org.eclipse.
i mport org.eclipse.
i mport org.eclipse.
i mport org.eclipse.
i mport org.eclipse.
i mport org.eclipse.
i mport org.eclipse.
i mport org.eclipse.
i mport org.eclipse.
i mport org.eclipse.
i mport org.eclipse.
i mport org.eclipse.
i mport org.eclipse.
i mport org.eclipse.
i mport org.eclipse.
i mport org.eclipse.
i mport org. eclipse.
i mport org.eclipse.
i mport org. eclipse.

/**

* An exanpl e showing how to create a nulti-page editor.

core. resources
core. resources
core. resources
core. resources

core.

SW .
SW .
SW .
SW .

sut

SWI;

custom Styl edText ;
events. Sel ecti onAdapt er;
events. Sel ecti onEvent ;
gr aphi cs. Font ;

gr aphi cs. Font Dat a;
'ayout . Fil | Layout ;

. | Mar ker ;

. | Resour ceChangeEvent ;

. | Resour ceChangelLi st ener;
. Resour cesPl ugi n;
runtinme. | Progresshbnitor;

j face. di al ogs. Error Di al og;

SWt .
SW .
SW .
SW .
SW .
SW .
SW .
SW .

| ayout . Gri dDat a;

| ayout. Gri dLayout ;
wi dgets. Button;
wi dget s. Conposi t e;

wi dget s. Di spl ay;

ui . 1 de. | DE;

* This exanpl e has 3 pages:

<ul >

* % ok X *

</ ul >
*/

public class Milti PageEditor
ext ends Ml ti PageEdit or Part

i npl enent s | Resour ceChangeli st ener

/** The text editor used in page O.
private TextEditor

edi tor;

/** The font chosen in page 1.
private Font font;

/** The text w dget used in page 2.

private Styl edText text;

/**

Building Eclipse plug-ins using templates
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*/

.wi dget s. Font Di al og;
* .

ui eai tors.text. Text Editor;
ui . part.FileEditorlnput;
ui . part. Ml ti PageEditorPart;

<l i >page O contains a nested text editor.
<li>page 1 allows you to change the font used in page 2
<l i >page 2 shows the words in page O in sorted order

*/

*/
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* Creates a nulti-page editor exanple.
*/
public MultiPageEditor() {
super () ;
Resour cesPl ugi n. get Wor kspace() .
addResour ceChangeli st ener (t hi s);
}

/**
* Creates page 0 of the multi-page editor,
*/whi ch contains a text editor.
*
voi d creat ePage0() ({
try {
editor = new TextEditor();
int index = addPage(editor, getEdit
set PageText (i ndex, editor.getTitl e(
} catch (PartlnitException e) {
Error D al og. openError (
getSite().getShell (),
"Error creating nested text editor",
nul |,
e.getStatus());

rinput());
)

0
)

}
}
/**
* Creates page 1 of the multi-page editor,
* which allows you to change the font used in page 2.
*/
voi d createPagel() ({

Conposite conposite =

new Conposite(get Container(), SW.NONE);
GidLayout |ayout = new GidLayout();
conposi te. set Layout (| ayout) ;
| ayout . nunCol umms = 2;

Button fontButton = new Button(conposite, SW.NONE);
GidData gd = new Gi dDat a(G i dDat a. BEG NNI NG) ;

gd. hori zont al Span = 2;

font Button. set Layout Dat a( gd) ;

font Butt on. set Text (" Change Font...");

font Button. addSel ecti onLi st ener (new Sel ecti onAdapter() {
public void wi dget Sel ect ed( Sel ecti onEvent event) ({
set Font () ;

1)

int index = addPage(conposite);
set PageText (i ndex, "Properties");

/**
* Creates page 2 of the nulti-page editor,
*/Wnich shows the sorted text.
*
voi d createPage2() {
Conposite conposite =
new Conposite(get Container(), SWI. NONE);
Fi |l Layout |ayout = new Fill Layout();
conposi te. set Layout (| ayout) ;
text = new Styl edText (
conposite, SW.H SCROLL | SWI. V_SCROLL);
text.set Edi t abl e(fal se);

int index = addPage(conposite);
set PageText (i ndex, "Preview');
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}
/**
* Creates the pages of the nmulti-page editor.
*/
protected void createPages() {
cr eat ePage0() ;
creat ePagel();
creat ePage2();

/**
* The <code>Mil ti PageEditor Part</code> inpl ementati on of
* this <code>l Wr kbenchPart </ code> met hod di sposes al |
* nested editors.
*/Subclasses may extend.
*
public void dispose() {
Resour cesPl ugi n. get Wr kspace() .
renoveResour ceChangelLi st ener (this);
super . di spose();

/**
* Saves the nulti-page editor's docunent.
*/
public void doSave(l Progresshonitor monitor) {
get Edi t or (0) . doSave(noni tor);

/**
* Saves the nulti-page editor's docunent as another
* file.

* Also updates the text for page 0's tab, and updates
* this multi-page editor's input
*/to correspond to the nested editor's.
*
public void doSaveAs() {
| EditorPart editor = getEditor(0);
edi tor. doSaveAs() ;
set PageText (0, editor.getTitle());
set | nput (edi tor. getEditorlnput());

/* (non-Javadoc)
* Met hod decl ared on | EditorPart
*
/
public void gotoMarker (I Marker marker) {
set Acti vePage(0);
| DE. got oMar ker (get Edi tor (0), marker);

/-k*
* The <code>Mil ti PageEdi t or Exanpl e</ code> i npl enent ati on
* of this nethod
* checks that the input is an instance of
*/ <code>| Fi | eEdi t or | nput </ code>.
*
public void init(
IEditorSite site, |IEditorlnput editorlnput)
throws PartlnitException

if (!(editorlnput instanceof |FileEditorlnput))
throw new Partl nitException(
"Invalid Input: Miust be IFileEditorlnput");
super.init(site, editorlnput);

/* (non-Javadoc)
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* Met hod declared on | EditorPart.

*/

publ i ¢ bool ean i sSaveAsAl | owed() {
return true;

/**
* Cal cul ates the contents of page 2 when the it is
* activated.
*/
protected void pageChange(int newPagel ndex) {
super . pageChange( newPagel ndex) ;
i f (newPagel ndex == 2) {

sortWords();
}
}
/**
* Closes all project files on project close.
*/

public void resourceChanged(
final | ResourceChangeEvent event)

i f(event.get Type() == | ResourceChangeEvent. PRE_CLGCSE) {
Di spl ay. get Def aul t (). asyncExec(new Runnabl e() {
public void run(){
| Wor kbenchPage[] pages =
get Site().get WrkbenchW ndow() . get Pages() ;
for (int i = 0; i<pages.length; i++){
if(((FileEditorlnput)editor.getEditorlnput())
.getFile().getProject().equal s(
event . get Resource()))

| EditorPart editorPart =
pages[i].findEditor(
edi tor. get Edi t or | nput

0
pages[i].cl oseEditor(editor

)
Part, true);

}
1)
}
}
/**

* Sets the font related data to be applied to the text
* in page 2.
*/

voi d set Font ()
FontDi al og fontDi al og =
new Font Di al og(getSite().getShell());

font D al og. set Font Li st (text. getFont().getFontData());
Font Data fontData = fontDi al og. open();
if (fontData != null) {
if (font !'= null)
font.di spose();
font = new Font(text.getDisplay(), fontData);
text.set Font (font);
}
}

/**
* Sorts the words in page 0, and shows themin page 2.
*/
voi d sortWords() {
String editorText =
edi t or . get Docunent Pr ovi der () . get Documnent (
editor.getEditorlnput()).get();
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The

StringTokeni zer tokenizer =
new StringTokeni zer (editor Text,
"ANtAn\r\f! @\ u0024%&()-" +
A B R TR R S ] R I
ArrayLi st editorWrds = new ArraylList();
whil e (tokeni zer. hasMoreTokens()) {
edi t or Wor ds. add(t okeni zer. next Token());

Col | ections. sort(editorWrds, Collator.getlnstance());
StringWiter displayText = new StringWiter();
for (int i =0; | < editorWrds.size(); i++)
di splayText.wite(((String) editorWrds.get(i)));
di spl ayText.write(
System get Property("line. separator"));

}
text. set Text (di spl ayText.toString());

code for the Mul t i PageEdi t or Contri but or . j ava class:

package comibmtutorial.tenplates. editors;

i mport org.eclipse.jface.action.?*;

i mport org.eclipse.]face. di al ogs. MessageD al og;

i mport org.eclipse.ui.lActionBars;

i mport org.eclipse.ui.lEditorPart;

i mport org.eclipse.ui.lWrkbenchActi onConst ants;

i mport org.eclipse.ui.PlatfornJ;

i mport org.eclipse.ui.actions. Acti onFactory;

i mport org.eclipse.ui.ide.!|DE;

i mport org.eclipse.ui.ide.lDEActionFactory;

i mport org.eclipse.ui.part. MiltiPageEditorActionBarContributor;
i mport org.eclipse.ui.texteditor. | TextEditor;

i mport org.eclipse.ui.texteditor. | TextEditorActi onConstants;

*

/

* Ok kX X F X

*/

Manages the installation/deinstallation of global
actions for nulti-page editors.

Responsi bl e for the redirection of global actions to
the active editor.

Mul ti - page contributor replaces the contributors for the
i ndividual editors in the nmulti-page editor.

public class MiltiPageEditorContributor

ext ends Ml ti PageEdit or Acti onBar Contri but or

private | EditorPart activeEditorPart;
private Action sanpl eActi on;

/

* %

* Creates a nulti-page contributor.
*/

public MiltiPageEditorContributor() {

/

super () ;
creat eActions();

* %

* Returns the action registed with the given
* text editor.

* @eturn | Action or null if editor is null.
Z

protected | Action getAction(
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return (editor == null 2
null : editor.getAction(actionlD));

/* (non-Javadoc)
* Met hod declared in
* Abstract Mul ti PageEdi t or Acti onBar Cont ri but or.

*/
public void setActivePage(lEditorPart part) {
if (activeEditorPart == part)
return;

activeEditorPart = part;

| Acti onBars actionBars = getActionBars();
if (actionBars != null)
| TextEditor editor = (part instanceof |TextEditor) ?
(I TextEditor) part : null;

actionBars. set G obal Acti onHandl er (
Act i onFact ory. DELETE. get 1 d(),
get Act i on(
editor, |TextEditorActionConstants. DELETE));
acti onBars. set G obal Acti onHandl er (
Acti onFact ory. UNDO. get I d(),
get Act i on(
editor, |TextEditorActionConstants. UNDO));
acti onBars. set G obal Acti onHandl er (
Acti onFact ory. REDO. get I d(),
get Act i on(
editor, | TextEditorActionConstants. REDO));
acti onBars. set G obal Acti onHandl er (
ActionFactory. CUT. getl d(),
get Act i on(
editor, | TextEditorActi onConstants. CUT));
actionBars. set @ obal Acti onHandl er (
Act i onFact ory. COPY. get I d(),
get Acti on(
editor, |TextEditorActionConstants. COPY));
acti onBars. set @ obal Acti onHandl er (
Acti onFact ory. PASTE. get 1 d(),
get Acti on(
editor, |TextEditorActi onConstants. PASTE));
acti onBars. set d obal Acti onHandl er (
ActionFactory. SELECT_ALL. getld(),
get Acti on(
edi tor,
| Text Edi t or Acti onConst ants. SELECT_ALL));
actionBars. set G obal Acti onHandl er (
ActionFactory. FI ND. getld(),
get Acti on(
editor, |TextEditorActi onConstants. FIND));
actionBars. set G obal Acti onHandl er (
| DEAct i onFact or y. BOOKMARK. get | d(),
get Acti on(
editor, |DEActi onFactory. BOOKMARK. getld()));
) actionBars. updat eActi onBars();
}

private void createActions() {
sanpl eAction = new Action() {
public void run()
MessageDi al og. openl nf or mat i on(
nul |,
"Tenpl ates Plug-in",
"Sanpl e Action Executed");
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sanpl eActi on. set Text (" Sanpl e Action");
sanpl eActi on. set Tool Ti pText ("Sanpl e Action tool tip");
sanpl eActi on. set | mageDescri pt or (
Pl at f or mJI . get Wor kbench() . get Shar edl mages() .
get | mageDescri pt or (
) | DE. Shar edl nages. | MG_0OBJS_TASK TSK)) ;

public void contributeToMenu(l MenuManager nanager) {
| MenuManager menu = new MenuManager (" Editor &\Venu");
manager . prependToG oup(
I Wor kbenchAct i onConst ants. MB_ADDI TI ONS, nenu) ;
menu. add( sanpl eActi on) ;

public void contributeToTool Bar (| Tool Bar Manager manager)

manager . add( new Separator());
manager . add( sanpl eActi on);

This code is a contributor, which demonstrates how to customize the menu and
toolbar based on a particular editor in the methods cr eat eAct i ons,

cont ri but eToMenu, and cont ri but eToTool Bar . In this example, it adds a
Sample Action to the toolbar and to a new Editor Menu. It also demonstrates in

set Act i onPage and get Act i on methods how to disable global actions based on

the editor's state. In this example, global actions related to copy, paste, undo, etc.
are disabled for the second and third page of the wizard.

The code for the Sanpl eNewW zar d. j avaclass:

package comibmtutorial.tenplates.w zards;

i mport org.eclipse.jface.viewers. | StructuredSel ecti on;
i mport org.eclipse.jface.w zard. Wzard;

i mport org.eclipse.ui.lNewW zard;

i mport org.eclipse.ui.lWrkbench;

i mport org.eclipse.core.runtine.*;

i mport org.eclipse.jface.operation.*;

i mport java.lang.refl ect.|nvocati onTarget Excepti on;
i mport org.eclipse.jface. di al ogs. MessageDi al og;

i mport org.eclipse.jface.viewers. | Sel ecti on;

i mport org.eclipse.core.resources. *;

i mport org.eclipse.core.runtinme. CoreException;

i mport java.io.*;

i mport org.eclipse.ui.*;

i mport org.eclipse.ui.ide.|DE

/

*

This is a sanple new wi zard. Its role is to create a new
file resource in the provided container. If the

contai ner resource (a folder or a project) is selected
in the workspace when the wizard is opened, it wll
accept it as the target container. The w zard creates
one file with the extension "npe". If a sanple multi-
page editor (also available as a tenplate) is registered
for the sanme extension, it will be able to open it.

* % ok 3k X X 3k 3k X F

~
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public class Sanpl eNewW zard extends W zard
i mpl enents | NewW zard

private Sanpl eNewW zar dPage page;
private | Sel ection sel ection;

/**
* Constructor for Sanpl eNewW zar d.
*/
public Sanpl eNewW zard() {
super () ;
set NeedsPr ogresshoni tor (true);
}
/**
* Addi ng the page to the wi zard.
*/

public void addPages() {
page = new Sanpl eNewW zar dPage( sel ecti on);

addPage( page) ;
/**

* This method is called when 'Finish' button is pressed
* in the wizard. W will create an operation and run it
* using wi zard as execution context.

*/

publ i ¢ bool ean perfornFini sh() {
final String containerName = page. get Cont ai ner Name() ;
final String fil eName = page. get Fi | eName();
| Runnabl eWt hProgress op = new | Runnabl eWt hProgress()

public void run(lProgresshonitor nonitor)
throws I nvocationTarget Excepti on

try {

doFi ni sh(cont ai ner Name, fileName, nonitor);
} catch (CoreException e)

throw new | nvocati onTar get Excepti on(e);

} finally {
nmoni t or . done() ;
}
}
T
try
get Container().run(true, false, op);
} catch (InterruptedException e) {
return fal se;
} catch (lnvocati onTarget Exception e)

Thr owabl e real Exception = e. get Target Excepti on();
MessageDi al og. openErr or (

get Shel | (),

"Error", real Exception. get Message());
return fal se;

return true;

/**
* The worker method. It will find the container, create

* the file if nmissing or just replace its contents, and
* open the editor on the newy created file.
*/

private void doFi ni sh(
String contai ner Nane,
String fil eNane,
| Progresshbni tor nonitor)
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t hrows Cor eException

/1 create a sanple file
nmoni t or. begi nTask("Creating " + fileNane, 2);
| Wor kspaceRoot root =

Resour cesPl ugi n. get Wor kspace() . get Root () ;
| Resource resource = root.findMenber (

new Pat h( cont ai ner Nane) ) ;
if (!'resource.exists() ||

I (resource instanceof | Container))

t hr owCor eExcepti on(" Contai ner \"" +
contai nerNane + "\" does not exist.");

}
| Cont ai ner container = (IContainer) resource;
final IFile file =
font ai ner.getFile(new Path(fil eNane));
try
I nput Stream stream = openCont ent St reamn() ;
if (file.exists()) {
file.setContents(stream true, true, nonitor);
} else {
file.create(stream true, nonitor);

stream cl ose();
} catch (1 CException e) {

nmoni t or . wor ked(1) ;
nmoni t or . set TaskNane(" Opening file for editing...");
get Shel | (). get Di spl ay() . asyncExec(new Runnabl e() {
public void run() {
| Wor kbenchPage page =
Pl at f or mJl . get Wor kbench() .
get Act i veWbr kbenchW ndow() . get Act i vePage() ;
try {
| DE. openEdi t or (page, file, true);
% catch (PartlnitException e) {

}
rmnifor.worked(l);
}
/**
*We will initialize file contents with a sanple text.
*/

private | nputStream openContentStrean() {
String contents =
"This is the initial file contents for *.npe " +
"file that should be word-sorted in the " +
"Preview page of the nulti-page editor";
return new Byt eArrayl nput Stream contents. getBytes());

private void throwCoreException(String nmessage)
t hrows CoreException

| Status status =
new St at us(| Status. ERROR,
"comibmtutorial.tenpl ates",
| Status. OK, nmessage, null);
t hrow new Cor eExcepti on(status);

}

/**

* W will accept the selection in the workbench to see
*if we can initialize fromit.

* @ee | WrkbenchW zar d#i ni t (
& | Wor kbench, | StructuredSel ection)
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*/
public void init(lWrkbench workbench,
| StructuredSel ection sel ection)

this.selection = selection;

The wizard in this code is a standard wizard that displays pages, then generates
code in the doFi ni sh method. What is most interesting about this class is that in
per f or nFi ni sh, it demonstrates how to interact with Eclipse's process monitor for
tasks that take a long time.

SampleNewWizardPage.java class

The code for the Sanpl eNewW zar dPage. | ava class:

package comibmtutorial.tenplates.w zards;

i mport org.eclipse.jface.w zard. W zar dPage;

i mport org.eclipse.swt.w dgets. *;

i mport org.eclipse.sw.|ayout.*;

i mport org.eclipse.swt.SW;

i mport org.eclipse.core.resources. *;

i mport org.eclipse.core.runtimnme. Pat h;

i mport org.eclipse.sw.events. *;

i mport org.eclipse.ui.dial ogs. Cont ai ner Sel ecti onDi al og;
i mport org.eclipse.jface.viewers.*;

e "New' w zard page allows setting the container for
e newfile as well as the file nane. The page

will only accept file nane w thout the extension OR
with the extension that matches the expected one (npe).

public class Sanpl eNewW zar dPage ext ends W zar dPage {
private Text contai ner Text;
private Text fileText;
private | Sel ection sel ection;

/**

* Constructor for Sanpl eNewW zar dPage.
* @ar am pageNane
*/

publ i ¢ Sanpl eNewW zar dPage( | Sel ecti on sel ection) ({
super ("w zar dPage") ;
setTitle("Multi-page Editor File");
set Description("This wizard creates a new file with " +
"* npe extension that can be opened by a " +
"mul ti-page editor.");
this.selection = sel ection;

}

/**
* @ee | D al ogPage#creat eControl (Conposite)
*/

public void createControl (Conposite parent)

{
Conposi te contai ner = new Conposite(parent, SW.NULL);
GidLayout |ayout = new GidLayout();
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cont ai ner. set Layout (| ayout) ;

| ayout . nuntCol umms = 3;

| ayout . verti cal SpaC| ng = 9;

Label | abel = new Label (contai ner, SWI. NULL);
| abel . set Text (" &Cont ai ner:");

cont ai ner Text =
new Text (contai ner, SW. BORDER | SWI. S| NGLE) ;
GidData gd =
new Gri dDat a( Gri dDat a. FI LL_HORI ZONTAL) ;
cont ai ner Text . set Layout Dat a(gd) ;
cont ai ner Text . addMbdi fyLi st ener (new Modi fyLi stener () {
public void nodi fyText (MdifyEvent e)
di al ogChanged();

}
1)
Button button = new Button(cont ai ner, SWI. PUSH);
button. set Text( Browse. ..");

but t on. addSel ect i onLi st ener (new Sel ecti onAdapter() {
public void w dget Sel ect ed( Sel ecti onEvent e) {
handl eBr owse() ;
). }
abel = new Label (cont ai ner, SWI. NULL);
abel . set Text ("&Fil e name:");

—_———

fileText =
new Text (cont ai ner, SWI. BORDER | SWI. SI NGLE) ;
gd = new GidData(GidbData. Fl LL_HORI ZONTAL) ;
fil eText.setLayout Dat a(gd) ;
fil eText.addModifyLi stener(new MdifyListener() {
public void nodi fyText (MdifyEvent e) {
di al ogChanged() ;

1)

initialize();

di al ogChanged();

set Control (cont ai ner);

}
/**
* Tests if the current workbench selection is a suitable
* contai ner to use.
*/
private void initialize() {
if (selection!=null
&& sel ection.isEmpty()==fal se
&& sel ection instanceof |StructuredSel ection)

I StructuredSel ection ssel =
(I'StructuredSel ection)sel ection;
if (ssel.size()>1) return;
Obj ect obj = ssel.getFirstEl enment();
if (obj instanceof |Resource) {
| Cont ai ner cont ai ner;
if (obj instanceof | Container)
cont ai ner = (| Cont ai ner)obj;
el se
container = ((lResource)obj).getParent();

cont ai ner Text . set Text (
contai ner.getFull Path().toString());

fileText.setText("new file.nmpe");

/**
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* Uses the standard contai ner selection dialog to
*/choose the new value for the container field.
*
private void handl eBrowse() {
Cont ai ner Sel ecti onDi al og di al og =
new Cont ai ner Sel ecti onDi al og(
get Shel | (),
fReisourcesPl ugi n. get Wor kspace() . get Root (),
al se,

"Sel ect new file container");
i f (dialog.open() == ContainerSel ectionD al og. OK) {
oj ect[] result = dial og.getResult();
if (result.length == 1) {
cont ai ner Text . set Text (
((Path)result[0]).toOSString());

}
}

/**

* Ensures that both text fields are set.
*/

private void dial ogChanged() {

String contai ner = get Cont ai ner Nanme() ;
String fileNane = getFil eNanme();

if (container.length() == 0) {
updat eSt at us("Fi |l e cont ai ner nmust be specified");
return;

}
if (fileName.length() == 0) {
updat eSt at us("Fil e nane nust be specified");

return;
}
int dotLoc = fileNane.|astlndexOh('.");
if (dotLoc != -1) {
String ext = fileNane.substring(dotLoc + 1);
if (ext.equal slgnoreCase("npe") == false) {
updat eStatus("Fi |l e extensi on nust be \"npe\"");
return;

}
updat eSt atus(nul I');
}

private void updateStatus(String nessage) {
set Error Message( nessage) ;
set PageConpl et e( message == nul | );

public String getContainerNane() {
return contai ner Text. get Text();

public String getFileNane() {
return fileText.getText();

This code is a simple SWT wizard page. The most interesting characteristic of this
class is in the handl eBr owse method. This method uses Eclipse's
Cont ai ner Sel ecti onDi al og for displaying the folders in the workspace.
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Section 10. Summary

This tutorial just scratched the surface of Eclipse plug-in development. It
demonstrated how to create, test, debug, and package a basic plug-in. Then it
showed how to start developing your own plug-ins using the seven plug-in templates
as a starting point:

» Hello World

e Popup Menu

* Property Page

* View

» Perspective Extension
» Editor

* Multi-page Editor

You should now have a good understanding of how to take advantage of the plug-in
templates in Eclipse to reduce the coding and learning curve of generating your own
custom plug-ins.

Building Eclipse plug-ins using templates Trademarks
© Copyright IBM Corporation 2005. All rights reserved. Page 71 of 74


http://www.ibm.com/developerworks/ibm/trademarks/
http://www.ibm.com/legal/copytrade.shtml

developerWorks® ibm.com/developerWorks

Downloads
Description Name Size Download
method
Complete source os-eclplgnssource.zip 37KB HTTP
Information about download methods
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Resources

Learn

» Visit Eclipse.org for the latest downloads, news, articles, and announcements of
Eclipse.

» The Platform Plug-in Developers Guide provides documentation on extending
the base Eclipse Platform.

» The Eclipse Platform API Specification contains the Eclipse Platform Javadoc.

* The JDT Programmers Guide provides documentation on extending the Java
Development Tools.

* The Eclipse JDT API Specification contains the JDT Javadoc.

* The PDE Plug-in Guide provides documentation on extending the Plug-in
Development Environment.

« The PDE API Reference contains the PDE Javadoc.

» The Definitive Guide to SWT and JFace , by Rob Warner with Robert Harris
(Apress, 2004), provides thorough coverage of these two newer technologies.

* "Migrate your Swing applications to SWT" is a tutorial that contains a
comparison and mapping between SWT and Swing.

« "Debugging with the Eclipse Platform™ explains how to use the Eclipse
debugger.

» Find out more about Eclipse plug-ins.

» Find out more about Eclipse at the Eclipse Plug-in Resource Center and
Marketplace.

* Visit the developerWorks Open source zone for extensive how-to information,
tools, and project updates to help you develop with open source technologies
and use them with IBM's products.

Get products and technologies

* Innovate your next open source development project with IBM trial software,
available for download or on DVD.

Discuss

* Getinvolved in the developerWorks community by participating in
developerWorks blogs.
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